Bug 987734 - changelog: fix crash while enabling changelog
changelog: fix crash while enabling changelog
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Venky Shankar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 23:14 EDT by Venky Shankar
Modified: 2014-04-17 07:44 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 07:44:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Venky Shankar 2013-07-23 23:14:35 EDT
Description of problem:

Change-logging is off by default, when enabled could crash at time. This is because of a bug an incomplete routine completion during init().

Version-Release number of selected component (if applicable):
mainline
Comment 1 Anand Avati 2013-07-24 01:51:09 EDT
REVIEW: http://review.gluster.org/5380 (features/changelog: fixes when enabling changelog) posted (#1) for review on master by Venky Shankar (vshankar@redhat.com)
Comment 2 Anand Avati 2013-07-25 07:40:56 EDT
COMMIT: http://review.gluster.org/5380 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 131d78dd36bac795d50fee3b04969b5ea9cb613c
Author: Venky Shankar <vshankar@redhat.com>
Date:   Wed Jul 24 00:01:19 2013 +0530

    features/changelog: fixes when enabling changelog
    
    Other enhancements being:
          * ignore fops made by rebalance
          * ignore internally triggered fops
    
    BUG: 987734
    Change-Id: I7dd164ae3c209fdb8ec43a27e67b8846f937c93b
    Signed-off-by: Venky Shankar <vshankar@redhat.com>
    Reviewed-on: http://review.gluster.org/5380
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 3 Anand Avati 2013-09-13 10:37:39 EDT
REVIEW: http://review.gluster.org/5921 (features/changelog: fixes when enabling changelog) posted (#1) for review on release-3.4 by Avra Sengupta (asengupt@redhat.com)
Comment 4 Niels de Vos 2014-04-17 07:44:08 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.