Bug 987748 - Provide option to use/not use kernel-readdirp
Provide option to use/not use kernel-readdirp
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: fuse (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Pranith Kumar K
Sachidananda Urs
:
Depends On: 983477
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 01:32 EDT by Pranith Kumar K
Modified: 2013-09-23 18:41 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.12rhs.beta6-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 983477
Environment:
Last Closed: 2013-09-23 18:38:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2013-07-24 01:32:24 EDT
+++ This bug was initially created as a clone of Bug #983477 +++

Description of problem:
    By default fuse kernel readdirp usage in fuse xlator should be off.
    When mount option use-readdirp=yes is provided it should use
    fuse-kernel's readdirp.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Anand Avati on 2013-07-11 05:56:01 EDT ---

REVIEW: http://review.gluster.org/5322 (mount/fuse: Provide option to use/not use kernel-readdirp) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Anand Avati on 2013-07-11 05:58:28 EDT ---

REVIEW: http://review.gluster.org/5323 (mount/fuse: Provide option to use/not use kernel-readdirp) posted (#1) for review on release-3.4 by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Anand Avati on 2013-07-11 09:35:51 EDT ---

REVIEW: http://review.gluster.org/5322 (mount/fuse: Provide option to use/not use kernel-readdirp) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Anand Avati on 2013-07-11 09:38:50 EDT ---

REVIEW: http://review.gluster.org/5323 (mount/fuse: Provide option to use/not use kernel-readdirp) posted (#2) for review on release-3.4 by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Anand Avati on 2013-07-12 10:36:42 EDT ---

COMMIT: http://review.gluster.org/5322 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 61b09562b934b53dadcd566f6feb72301097933c
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Thu Jul 11 12:52:11 2013 +0530

    mount/fuse: Provide option to use/not use kernel-readdirp
    
    By default fuse kernel readdirp usage in fuse xlator is off.
    When mount option use-readdirp=yes is provided it starts using
    fuse-kernel's readdirp.
    
    Change-Id: Id37edc53b1adc1638186d956c2f74c1e4e48aa59
    BUG: 983477
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/5322
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

--- Additional comment from Anand Avati on 2013-07-12 13:30:38 EDT ---

COMMIT: http://review.gluster.org/5323 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit b92b98ef9a2d912273aeb29a82ffd25831a8eec3
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Thu Jul 11 12:52:11 2013 +0530

    mount/fuse: Provide option to use/not use kernel-readdirp
    
    By default fuse kernel readdirp usage in fuse xlator is off.
    When mount option use-readdirp=yes is provided it starts using
    fuse-kernel's readdirp.
    
    BUG: 983477
    Change-Id: Ibdaf1407d6f2a782a4a1916fad374f36fca6c5e7
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/5323
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 3 Sachidananda Urs 2013-08-05 08:06:17 EDT
Pranith, the bug description says: " By default fuse kernel readdirp usage in fuse xlator should be off."

But I believe that it should be `on' by default. Can you please confirm?
Comment 4 Pranith Kumar K 2013-08-05 08:33:17 EDT
After the fix for this bug went in there was another patch that changed default value to on.
Comment 5 Sachidananda Urs 2013-08-13 05:19:20 EDT
Verified on: glusterfs 3.4.0.18rhs built on Aug  7 2013 08:02:45

Now by default readdirp is on, and performance is far better.
Comment 6 Scott Haines 2013-09-23 18:38:33 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 7 Scott Haines 2013-09-23 18:41:26 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.