Bug 987755 - "resolve" linked inodes which have not been looked up
"resolve" linked inodes which have not been looked up
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: fuse (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Raghavendra G
Sachidananda Urs
:
Depends On: 979910
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 01:54 EDT by Raghavendra G
Modified: 2013-09-23 18:41 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.18rhs-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 979910
Environment:
Last Closed: 2013-09-23 18:38:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra G 2013-07-24 01:54:59 EDT
+++ This bug was initially created as a clone of Bug #979910 +++

Description of problem:
 with readdirplus support, kernel may not send lookup before
    a path based fop. Though readdirplus of each xlators do
    some things done in lookup, its not complete enough to replace
    a lookup. Hence its necessary that a lookup should be sent
    before we go ahead with path based fop.


Version-Release number of selected component (if applicable):
mainline

How reproducible:
consistently

Steps to Reproduce:
conifiguration: Two node replicate, fuse with readdirplus support (RHEL 6.4)

1. mount a glusterfs volume with existing data.
2. start copying from glusterfs mountpoint (it doesn't matter whether destination is glusterfs or not).
3. kill first (0th) brick of afr.

Actual results:
cp fails with ENOTCONN errors

Expected results:
cp shouldn't fail since 2nd brick is up and running.

Additional info:

--- Additional comment from Anand Avati on 2013-07-01 03:03:33 EDT ---

REVIEW: http://review.gluster.org/5267 (mount/fuse: "resolve" linked inodes which have not been looked up.) posted (#3) for review on master by Raghavendra G (rgowdapp@redhat.com)

--- Additional comment from Anand Avati on 2013-07-02 01:03:39 EDT ---

REVIEW: http://review.gluster.org/5267 (mount/fuse: "resolve" linked inodes which have not been looked up.) posted (#4) for review on master by Raghavendra G (rgowdapp@redhat.com)

--- Additional comment from Anand Avati on 2013-07-23 07:19:38 EDT ---

REVIEW: http://review.gluster.org/5267 (mount/fuse: "resolve" linked inodes which have not been looked up.) posted (#5) for review on master by Raghavendra G (rgowdapp@redhat.com)

--- Additional comment from Anand Avati on 2013-07-23 21:59:48 EDT ---

REVIEW: http://review.gluster.org/5267 (mount/fuse: "resolve" linked inodes which have not been looked up.) posted (#6) for review on master by Raghavendra G (rgowdapp@redhat.com)

--- Additional comment from Anand Avati on 2013-07-23 22:02:28 EDT ---

REVIEW: http://review.gluster.org/5267 (mount/fuse: "resolve" linked inodes which have not been looked up.) posted (#7) for review on master by Raghavendra G (rgowdapp@redhat.com)

--- Additional comment from Anand Avati on 2013-07-23 22:06:23 EDT ---

REVIEW: http://review.gluster.org/5267 (mount/fuse: "resolve" linked inodes which have not been looked up.) posted (#8) for review on master by Raghavendra G (rgowdapp@redhat.com)

--- Additional comment from Anand Avati on 2013-07-23 22:11:26 EDT ---

REVIEW: http://review.gluster.org/5267 (mount/fuse: "resolve" linked inodes which have not been looked up.) posted (#9) for review on master by Raghavendra G (rgowdapp@redhat.com)

--- Additional comment from Anand Avati on 2013-07-23 22:18:11 EDT ---

REVIEW: http://review.gluster.org/5267 (mount/fuse: "resolve" linked inodes which have not been looked up.) posted (#10) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 2 Amar Tumballi 2013-08-01 08:15:17 EDT
This bug is actually important for supporting readdirplus support in glusterfs, which is needed for performance.

https://code.engineering.redhat.com/gerrit/#/c/11021/
Comment 3 Sachidananda Urs 2013-08-19 06:09:21 EDT
Verified on: glusterfs 3.4.0.19rhs built on Aug 14 2013 00:11:42

Tried to reproduce with the steps below:

Steps to Reproduce:
conifiguration: Two node replicate, fuse with readdirplus support (RHEL 6.4)

1. mount a glusterfs volume with existing data.
2. start copying from glusterfs mountpoint (it doesn't matter whether destination is glusterfs or not).
3. kill first (0th) brick of afr.

Actual results:
cp fails with ENOTCONN errors

======================

Unable to reproduce, marking verified.
Comment 4 Scott Haines 2013-09-23 18:38:33 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 5 Scott Haines 2013-09-23 18:41:26 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.