Bug 987814 - [engine][neutron] Port leftover if hot-plug new vNIC fails
[engine][neutron] Port leftover if hot-plug new vNIC fails
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
3.3
Unspecified Unspecified
medium Severity high
: ---
: 3.4.1
Assigned To: Mike Kolesnik
Meni Yakove
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 04:15 EDT by Mike Kolesnik
Modified: 2014-05-08 09:38 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-08 09:38:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 25478 None MERGED engine: Remove port if hot plug new ext. nic fails Never
oVirt gerrit 25603 None MERGED engine: Remove port if hot plug new ext. nic fails Never

  None (edit)
Description Mike Kolesnik 2013-07-24 04:15:50 EDT
Description of problem:
When creating a new vNIC and choosing to hot-plug it, If hot-plug vNIC fails, the port remains on Neutron but doesn't exist on oVirt side anymore.
Later on when you try to add a vNIC with the same MAC address, the add will fail since port already exists on Neutron.


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Open an "add new nic" dialog on a running VM
2. Select the neutron network, but don't click OK yet
3. Now quickly:
3.1. Block host-engine communication via iptables
3.2. Click OK
4. The "add vNIC" should fail with a provider error
5. Restore communication to the host
6. Try click OK again
  
Actual results:
The vNIC addition will fail
The leftover port can be seen on the neutron side on the /ports resource


Expected results:
The vNIC addition should succeed
The leftover port shouldn't be seen on the neutron side on the /ports resource


Additional info:
Comment 1 Sandro Bonazzola 2014-05-08 09:38:14 EDT
This is an automated message

oVirt 3.4.1 has been released:
 * should fix your issue
 * should be available at your local mirror within two days.

If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.