Bug 987837 - Audacity crashes when equalizer effect is selected
Audacity crashes when equalizer effect is selected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: audacity (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Manuel F Martinez
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 05:23 EDT by Giulio A.
Modified: 2014-02-24 14:35 EST (History)
5 users (show)

See Also:
Fixed In Version: audacity-2.0.4-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-15 03:15:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Giulio A. 2013-07-24 05:23:54 EDT
Description of problem:
After a fresh installation of Fedora 19 on my PC, Audacity always crashes after selection of equalizer effect from main menu.

Version-Release number of selected component (if applicable):
audacity-freeworld-2.0.3-1.fc19.x86_64

Steps to Reproduce:
1. Import into Audacity any type of audio
2. Select "Equalizer" from effects main menu
3. Audacity crashes

Expected results:
Audacity shows window with settings of equalizer effect
Comment 1 Giulio A. 2013-07-24 05:40:18 EDT
I have temporarily removed all EQCurves and EQBackup XML files from local audacity data folder, stored into ~/.audacity-data, but the issue persists.
Comment 2 Mark Walker 2013-08-04 16:32:41 EDT
(In reply to Giulio A. from comment #0)
> Description of problem:
> After a fresh installation of Fedora 19 on my PC, Audacity always crashes
> after selection of equalizer effect from main menu.
> 
> Version-Release number of selected component (if applicable):
> audacity-freeworld-2.0.3-1.fc19.x86_64
> 
> Steps to Reproduce:
> 1. Import into Audacity any type of audio
> 2. Select "Equalizer" from effects main menu
> 3. Audacity crashes
> 
> Expected results:
> Audacity shows window with settings of equalizer effect

Audacity freezes in play mode for me while just editing. Rest of system operates as normal and I can kill Audacity and then it recovers what files it can when I re-open it. I usually don't lose too much work when it recovers the files, but I do save more often than I used to because of this. This started in Fedora 18 just before the Fedora 19 release (I hope this might help identify which Audacity update caused it), and has continued in Fedora 19. If there are any config or other system or log files that might help, please let me know what they are and I can provide them. Thanks.
Comment 3 Bartz Klauser 2013-09-04 08:06:23 EDT
I have that same problem as well. I was trying to improve the music file by equalizing, but it crashes anytime. No other solutions for this bug.
Comment 4 Giulio A. 2013-09-04 09:16:06 EDT
A possible, temporary workaround to this annoying bug is to uninstall audacity package for fedora 19, and install via rpm file the same audacity package, with the same version, for fedora 18.

This package works, with equalizer too.

I hope this info can be useful for users, but especially for the closing of this annoying bug. 

Obviously, the Audacity package for fedora 18 ( that works ) will be updated to the Audacity package for fedora 19 ( that doesn't work ) at the first global system update. Remember that.
Comment 5 David Timms 2013-09-15 02:13:38 EDT
Note: audacity-freeworld is not in the fedora repositories.

Can you confirm that the issue continues on audacity-2.0.3 rather than audacity-freeworld ?

Can you try both of:

<http://kojipkgs.fedoraproject.org//work/tasks/6437/5936437/audacity-2.0.4-1.fc19.x86_64.rpm>

and

<http://buildsys.rpmfusion.org/plague-results/fedora-19-rpmfusion_free/audacity-freeworld/2.0.4-1.fc19/x86_64/audacity-freeworld-2.0.4-1.fc19.x86_64.rpm>
Comment 6 David Timms 2013-09-15 03:15:32 EDT
Another bug report 999145 has a full backtrace for same issue, closing this bug.

*** This bug has been marked as a duplicate of bug 999145 ***
Comment 7 Fedora Update System 2013-09-22 17:19:26 EDT
audacity-2.0.4-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/audacity-2.0.4-2.fc20
Comment 8 Fedora Update System 2013-09-22 17:20:01 EDT
audacity-2.0.4-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/audacity-2.0.4-2.fc19
Comment 9 Fedora Update System 2013-09-22 17:20:36 EDT
audacity-2.0.4-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/audacity-2.0.4-2.fc18
Comment 10 Fedora Update System 2013-09-28 21:26:22 EDT
audacity-2.0.4-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-10-14 03:09:35 EDT
audacity-2.0.4-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2013-10-14 13:15:45 EDT
audacity-2.0.4-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Mike Stefanelli 2014-02-24 14:35:15 EST
Not sure if this is related, but I was having major problems using Audacity after going to Fedora 19. Where the audio file would load but would not play correctly(would only hear static), then audacity would hang if I tried to stop the playback. For me this turned out to be a configuration problem in pulse audio.If I would go to the configuration tab in Volume control for pulse audio and select "Analog Stereo Duplex" for the Built-in Audio profile. before starting Audacity everything works fine. Hope this helps someone.

Note You need to log in before you can comment on or make changes to this bug.