Bug 987887 - Error message when reports portal is not installed
Error message when reports portal is not installed
Status: CLOSED WORKSFORME
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3
Assigned To: Mooli Tayer
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 07:19 EDT by Assaf Muller
Modified: 2013-10-17 10:40 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 10:40:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Assaf Muller 2013-07-24 07:19:07 EDT
Description of problem:
The reports portal is not installed on a fresh oVirt 3.3 install.
When clicking on the reports portal the following message is returned:
"Page: Reports is not legal."

The error message is not proper English. More importantly: The engine-setup script nor the error message mention the fact that you need to install the reports portal separately. How is the user supposed to know this?

I suggest we change the error message to be more informative so that the user knows how to install the reports portal.

Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.3.0-0.3.beta1.fc19
Comment 1 Mooli Tayer 2013-10-17 10:40:41 EDT
This issue has already been resolved by commit 7ae9e10ce633b3e55666fc9cf5fe0b7f2d4daba3.

There's a new message now:
"The reports application isn't installed."

It has been included since engine_3.2:
http://gerrit.ovirt.org/#/q/Ie77e6a063e1522b2e108076a240939ca1dae272e,n,z

Note You need to log in before you can comment on or make changes to this bug.