Bug 987978 - AttributeError: 'dict' object has no attribute 'split'
AttributeError: 'dict' object has no attribute 'split'
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.0
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: David Shea
Release Test Team
abrt_hash:7861acbaf475a881f5c74ffdae6...
:
Depends On: 969313
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 09:45 EDT by David Shea
Modified: 2014-06-17 21:35 EDT (History)
16 users (show)

See Also:
Fixed In Version: anaconda-19.31.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 969313
Environment:
Last Closed: 2014-06-13 05:42:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Shea 2013-07-24 09:45:17 EDT
+++ This bug was initially created as a clone of Bug #969313 +++

Description of problem:
Tried to Start Fedora 19 Beta Anaconda from DVD
The following was filed automatically by anaconda:
anaconda 19.30-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 294, in nm_ntp_servers_from_dhcp
    for ip in options.unpack().split(" "):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 897, in _get_ntp_servers_from_dhcp
    ntp_servers = nm.nm_ntp_servers_from_dhcp()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 919, in wait_for_connecting_NM_thread
    _get_ntp_servers_from_dhcp(ksdata)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'dict' object has no attribute 'split'

Version-Release number of selected component:
anaconda-19.30-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 rd.live.check quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 919, in wait_for_connecting_NM_thread
    _get_ntp_servers_from_dhcp(ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 897, in _get_ntp_servers_from_dhcp
    ntp_servers = nm.nm_ntp_servers_from_dhcp()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 294, in nm_ntp_servers_from_dhcp
    for ip in options.unpack().split(" "):
AttributeError: 'dict' object has no attribute 'split'

--- Additional comment from Marcus Moeller on 2013-05-31 03:48:42 EDT ---



--- Additional comment from Marcus Moeller on 2013-05-31 03:48:46 EDT ---



--- Additional comment from Marcus Moeller on 2013-05-31 03:48:50 EDT ---



--- Additional comment from Marcus Moeller on 2013-05-31 03:48:54 EDT ---



--- Additional comment from Marcus Moeller on 2013-05-31 03:49:00 EDT ---



--- Additional comment from Marcus Moeller on 2013-05-31 03:49:04 EDT ---



--- Additional comment from Marcus Moeller on 2013-05-31 03:49:08 EDT ---



--- Additional comment from Marcus Moeller on 2013-05-31 03:49:14 EDT ---



--- Additional comment from Marcus Moeller on 2013-05-31 03:49:18 EDT ---



--- Additional comment from Marcus Moeller on 2013-05-31 03:49:22 EDT ---



--- Additional comment from Marcus Moeller on 2013-05-31 03:49:26 EDT ---



--- Additional comment from Sylvain Lapierre on 2013-06-22 13:38:55 EDT ---

Description of problem:
boot on dvd fedora 19 beta mate compiz
setup wifi
install to hard disk

lon the hd a fedora 18 security spin is install
no other OS


Version-Release number of selected component:
anaconda-19.30-1.fc19.x86_64

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-MATE-Compiz-x86_64-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
other involved packages: python-libs-2.7.4-4.fc19.x86_64
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 919, in wait_for_connecting_NM_thread
    _get_ntp_servers_from_dhcp(ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 897, in _get_ntp_servers_from_dhcp
    ntp_servers = nm.nm_ntp_servers_from_dhcp()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 294, in nm_ntp_servers_from_dhcp
    for ip in options.unpack().split(" "):
AttributeError: 'dict' object has no attribute 'split'

--- Additional comment from Sebastian Pölsterl on 2013-07-02 14:36:28 EDT ---

Tried to start 'Install to Hard Drive'

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:UUID=6A57-F544 rootfstype=vfat ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-libs-2.7.5-1.fc19.x86_64
package:        anaconda-19.30.13-1.fc19.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'dict' object has no attribute 'split'
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19

--- Additional comment from Sylvain Lapierre on 2013-07-02 21:32:53 EDT ---

dual boot system  win 7 x64 and security spin 18 x64

boot on cd
start install
setup wifi


cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Security-x86_64-19-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-libs-2.7.5-1.fc19.x86_64
package:        anaconda-19.30.13-1.fc19.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'dict' object has no attribute 'split'
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19

--- Additional comment from Stuart D Gathman on 2013-07-02 22:24:27 EDT ---

Booted liveCD
Ran Compiz fusion Icon, spun the cube. 
Exited all windows, opened "Install to Disk"
Boom!

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-MATE-Compiz-i686-19- rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.i686
other involved packages: python-libs-2.7.5-1.fc19.i686
package:        anaconda-19.30.13-1.fc19.i686
packaging.log:  
product:        Fedora
reason:         AttributeError: 'dict' object has no attribute 'split'
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19

--- Additional comment from Stuart D Gathman on 2013-07-02 23:16:46 EDT ---

I see a variety of spins, and both CD and USB here.  So the trigger must be what is already on the disk.  Or else lots of people are downloading, attempting to install, and giving up in disgust.

In my case, there is already a Fedora 17 installation, with LVM and root and home LVs (and some additional LVs).

--- Additional comment from Sylvain Lapierre on 2013-07-03 21:08:17 EDT ---

previous install aleredy crashed
previous OS is deft linux 8 beta X64 using grub

with Parted Magic delete partitions create new partition table
one boot ended with grub rescue mode

start fed 19 gnome x64
setup wifi
try install to disk

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-19-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-libs-2.7.5-1.fc19.x86_64
package:        anaconda-19.30.13-1.fc19.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'dict' object has no attribute 'split'
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19

--- Additional comment from Stuart D Gathman on 2013-07-03 21:43:33 EDT ---

BTW, this is on the release ISO - it is still broken. Don't ignore this because it was first reported on the Beta!

--- Additional comment from Stuart D Gathman on 2013-07-04 10:25:17 EDT ---

nirik and some others looked at the backtrace and said that it had to do with network environment, not disk contents - indeed the crash is in nm.py.  He thought it was caused by dhcp6 on the network (and I do indeed run dhcp6).  
In any case, the workaround is simply to unplug the network cable and/or not connect the wireless.  I *may* try disabling dhcpd6.

--- Additional comment from Sylvain Lapierre on 2013-07-04 17:26:07 EDT ---

this time on my first i didn't start the wifi, no wire cable an it works

--- Additional comment from Sylvain Lapierre on 2013-07-05 06:24:34 EDT ---

Finally, I can install Fed 19 on 3 differents laptops simply by not connecting the wifi to my network. Previous installation on any of the 3 failed.

--- Additional comment from marcindulak on 2013-07-08 07:20:07 EDT ---

(In reply to Stuart D Gathman from comment #19)
> nirik and some others looked at the backtrace and said that it had to do
> with network environment, not disk contents - indeed the crash is in nm.py. 
> He thought it was caused by dhcp6 on the network (and I do indeed run
> dhcp6).  
> In any case, the workaround is simply to unplug the network cable and/or not
> connect the wireless.  I *may* try disabling dhcpd6.

I confirm it has something to do with IPv6.
I'm installing using pxe/kickstart so unplugging the cable is not an option.
The --noipv6 kickstart option helps:
network --bootproto=dhcp --onboot yes --noipv6

--- Additional comment from jeremy rutman on 2013-07-09 15:49:41 EDT ---

deleted exfat partition using gparted after booting from fedora install usb

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=LIVE rootfstype=vfat rw rd.live.image rd.live.overlay=LABEL=LIVE quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-libs-2.7.5-1.fc19.x86_64
package:        anaconda-19.30.13-1.fc19.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'dict' object has no attribute 'split'
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19
Comment 2 David Shea 2013-07-24 09:54:11 EDT
Patch pushed to rhel7-branch
Comment 5 Jan Stodola 2014-04-09 09:23:20 EDT
The code that caused the traceback is no longer present in anaconda-19.31.75-1.el7.

Setting Verified: SanityOnly
Comment 6 Ludek Smid 2014-06-13 05:42:08 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.