Bug 987983 - Please include oqgraph storage engine
Please include oqgraph storage engine
Status: CLOSED NOTABUG
Product: Red Hat Software Collections
Classification: Red Hat
Component: mariadb (Show other bugs)
mariadb55
All Linux
high Severity high
: ---
: 1.0
Assigned To: Honza Horak
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 09:51 EDT by Julio Entrena Perez
Modified: 2013-07-25 01:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-25 01:38:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julio Entrena Perez 2013-07-24 09:51:19 EDT
Description of problem:
Current mariadb55 builds do not include 'oqgraph' storage engine (just the test suite for it).

Version-Release number of selected component (if applicable):
mariadb55-ariadb-5.5.30-9.el6

How reproducible:
Always.

Steps to Reproduce:
1. 
2.
3.

Actual results:


Expected results:


Additional info:
http://openquery.com/products/graph-engine
Comment 1 Colin Charles 2013-07-24 23:11:58 EDT
MariaDB 5.5 disabled OQGRAPH. In previous releases, it was at best an alpha storage engine. This is (IMHO) not a bug.
Comment 2 Honza Horak 2013-07-25 01:38:11 EDT
(In reply to Colin Charles from comment #1)
> MariaDB 5.5 disabled OQGRAPH. In previous releases, it was at best an alpha
> storage engine. This is (IMHO) not a bug.

Frankly, I'm also not sure the proposal is very feasible to do. It doesn't seem that upstream has been very active lately, at least regarding activity in bug reports and code commits.

So I'm closing this for now. If you still believe we should consider adding this engine, please, file a bug in Bugzilla under "RHEL RFE", while choosing an appropriate component.

Note You need to log in before you can comment on or make changes to this bug.