This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 988007 - [Patch] Canon: First start lets application crash due to lack of null pointer check
[Patch] Canon: First start lets application crash due to lack of null pointer...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sane-backends (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
: 923254 (view as bug list)
Depends On:
Blocks: 923254
  Show dependency treegraph
 
Reported: 2013-07-24 10:16 EDT by Andre Vehreschild
Modified: 2014-03-11 10:09 EDT (History)
2 users (show)

See Also:
Fixed In Version: sane-backends-1.0.24-4.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-11 08:58:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Preliminary patch to prevent crash. (748 bytes, patch)
2013-07-24 10:16 EDT, Andre Vehreschild
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 314337 None None None Never

  None (edit)
Description Andre Vehreschild 2013-07-24 10:16:07 EDT
Created attachment 777807 [details]
Preliminary patch to prevent crash.

Description of problem:
A missing null pointer check in the canon module leads to crashing application when scanning for input devices the first time.

Version-Release number of selected component (if applicable):
1.0.23

How reproducible:
Attach canon scsi scanner, start scanning app using sane.

Steps to Reproduce:
1.
2.
3.

Actual results:
App crashes.

Expected results:
App runs w/o crash.

Additional info:
Patch proposed also to the sane project.
Comment 1 David King 2014-03-11 08:58:03 EDT
This bug was fixed upstream in 1.0.24:

http://anonscm.debian.org/gitweb/?p=sane/sane-backends.git;a=commitdiff;h=d750ed0b1276a9a3475a2f819cfc86c3fecd0fd0

As this (actually, later) version (with other patches) is in both F19 and F20, closing this as ERRATA.
Comment 2 David King 2014-03-11 09:45:37 EDT
*** Bug 923254 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.