Bug 988222 - Plugins page crashed when loading that page
Plugins page crashed when loading that page
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
3.3
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Joey Boggs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 02:58 EDT by haiyang,dong
Modified: 2013-11-28 08:50 EST (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-28 08:50:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attached Screenshot (3.53 KB, image/png)
2013-07-25 02:58 EDT, haiyang,dong
no flags Details

  None (edit)
Description haiyang,dong 2013-07-25 02:58:58 EDT
Created attachment 778097 [details]
attached Screenshot

Description of problem:
Install ovirt-node-iso-3.0.0-5.0.3.vdsm.fc19.iso and enter into Plugins page,
Plugins page crashed with error info:
An error appeared in the UI: IndexError('list index out of range',)
(Seen throw an exception.png)

Version-Release number of selected component (if applicable):
http://resources.ovirt.org/releases/3.3/iso/ovirt-node-iso-3.0.0-5.0.3.vdsm.fc19.iso
       

How reproducible:
100%

Steps to Reproduce:


Actual results:

Expected results:


Additional info:
Comment 1 Mike Burns 2013-07-25 07:56:19 EDT
the problem is that the plugin page tries to show information even when plugins have been installed by default.  We need to have some other method to determine if plugins are installed or not.  

Currently, we look for files in /etc/ovirt-plugins.d, but files can be there even if we've installed them during installation

Note You need to log in before you can comment on or make changes to this bug.