Bug 988268 - Some radeon firmware files missing needed for kernel 3.11+
Some radeon firmware files missing needed for kernel 3.11+
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: linux-firmware (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Josh Boyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 04:38 EDT by Martin Kho
Modified: 2014-05-19 17:35 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-26 12:43:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kho 2013-07-25 04:38:54 EDT
Description of problem:
With the massive radeon push[1,2] (by Alex Deucher) in kernel 3.11 a new series of firmware files for radeon graphics cards were published [3]. The latest build in koji linux - firmware-20130724-27.git31f6b30.fc20 - is missing all <name>_smc.bin files.

My graphics card - AMD 6570 HD (a.k.a. TURKS) - for instance needs since kernel 3.11.0-0.rc0.git7.1.fc20.x86_64 microcode TURKS_smc.bin (see below dmesg). Because this file misses in the package X fals back to the VESA driver (see below Xorg.0.log).

I've manually added TURKS_smc.bin file to /usr/lib/firmware/radeon directory and that seems to solve this issue. 

Note: the 'missing' <name>_smc.bin files are listed in [3]

If you need more info, please let me know, thanks.


Output dmesg (partial):

[   61.567521] ni_cp: Failed to load firmware "radeon/TURKS_smc.bin"
[   61.567539] [drm:evergreen_startup] *ERROR* Failed to load firmware!
[   61.567547] radeon 0000:01:00.0: disabling GPU acceleration
[   61.568587] radeon 0000:01:00.0: ffff88030beff000 unpin not necessary
[   61.568590] radeon 0000:01:00.0: ffff88030beff000 unpin not necessary
[   61.568694] [drm:evergreen_init] *ERROR* radeon: MC ucode required for NI+.
[   61.568697] radeon 0000:01:00.0: Fatal error during GPU init

Output Xorg.0.log (partial):
[    88.397] (EE) open /dev/dri/card0: No such file or directory
[    88.397] (WW) Falling back to old probe method for fbdev
[    88.398] (II) Loading sub module "fbdevhw"
[    88.398] (II) LoadModule: "fbdevhw"
[    88.398] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[    88.398] (II) Module fbdevhw: vendor="X.Org Foundation"
[    88.398]    compiled for 1.14.2, module version = 0.0.2
[    88.398]    ABI class: X.Org Video Driver, version 14.1
[    88.398] (EE) open /dev/fb0: No such file or directory
[    88.398] (EE) Screen 0 deleted because of no matching config section.
[    88.398] (II) UnloadModule: "radeon"
[    88.398] (II) Loading sub module "vbe"
[    88.398] (II) LoadModule: "vbe"
[    88.398] (II) Loading /usr/lib64/xorg/modules/libvbe.so
[    88.434] (II) Module vbe: vendor="X.Org Foundation"
[    88.434]    compiled for 1.14.2, module version = 1.1.0
[    88.434]    ABI class: X.Org Video Driver, version 14.1
[    88.434] (II) Loading sub module "int10"
[    88.434] (II) LoadModule: "int10"
[    88.434] (II) Loading /usr/lib64/xorg/modules/libint10.so
[    88.548] (II) Module int10: vendor="X.Org Foundation"
[    88.549]    compiled for 1.14.2, module version = 1.0.0
[    88.549]    ABI class: X.Org Video Driver, version 14.1
[    88.549] (II) VESA(0): initializing int10
[    88.549] (II) VESA(0): Primary V_BIOS segment is: 0xc000
[    88.549] (II) VESA(0): VESA BIOS detected
[    88.549] (II) VESA(0): VESA VBE Version 3.0
[    88.549] (II) VESA(0): VESA VBE Total Mem: 16384 kB
[    88.549] (II) VESA(0): VESA VBE OEM: AMD ATOMBIOS
[    88.549] (II) VESA(0): VESA VBE OEM Software Rev: 13.12
[    88.549] (II) VESA(0): VESA VBE OEM Vendor: (C) 1988-2010, AMD Technologies Inc. 
[    88.549] (II) VESA(0): VESA VBE OEM Product: TURKS
[    88.549] (II) VESA(0): VESA VBE OEM Product Rev: 01.00


[1] http://lists.freedesktop.org/archives/dri-devel/2013-June/040706.html
[2] http://lists.freedesktop.org/archives/dri-devel/2013-July/041299.html
[3] http://people.freedesktop.org/~agd5f/radeon_ucode/

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. boot rawhide / fedora 20 with at least kernel 3.11.0-0.rc0.git7.1.fc20.x86_64
2. log in (I'm using kde)
3. consult dmesg/Xorg.0.org

Actual results:
X uses VESA driver

Expected results:
X uses ati/radeon driver

Additional info:
I saw someware a discussion about a possible licence issue, but couldn't find it anymore.
Comment 1 Martin Kho 2013-07-25 05:01:13 EDT
Hi,

Found the licence 'issue' under the heading "Missing Extra Firmware" : [1]

HTH,

Martin Kho


[1] http://www.x.org/wiki/radeonBuildHowTo/
Comment 2 Josh Boyer 2013-07-25 08:07:41 EDT
Dave, do you have any idea why these aren't in the linux-firmware repo like all the rest of the radeon firmware?
Comment 4 Josh Boyer 2013-07-25 20:19:25 EDT
(In reply to collura from comment #3)
> possible duplicate/related bugs:
> 
>   https://bugzilla.redhat.com/show_bug.cgi?id=988263
>   https://bugzilla.redhat.com/show_bug.cgi?id=988268
>   https://bugzilla.redhat.com/show_bug.cgi?id=988325
>   https://bugzilla.redhat.com/show_bug.cgi?id=988399

This bug is separate from the rest.  Thank you for creating the list though.
Comment 5 Martin Kho 2013-07-26 12:33:23 EDT
Hi,

linux-firmware-20130724-29.git31f6b30.fc20 - today pushed by airlied - solved this issue. This report can be closed.

Thanks,

Martin Kho
Comment 6 Josh Boyer 2013-07-26 12:43:26 EDT
Yep, thanks for the report Martin.  And thanks for the quick fix Dave.
Comment 7 Fedora Update System 2013-09-04 12:07:31 EDT
linux-firmware-20130724-29.git31f6b30.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/linux-firmware-20130724-29.git31f6b30.fc19
Comment 8 Fedora Update System 2013-09-04 12:08:42 EDT
linux-firmware-20130724-0.3.git31f6b30.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/linux-firmware-20130724-0.3.git31f6b30.fc18
Comment 9 Fedora Update System 2013-09-11 21:55:03 EDT
linux-firmware-20130724-29.git31f6b30.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-09-20 12:23:01 EDT
linux-firmware-20130724-0.3.git31f6b30.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.