Bug 988279 - [abrt] WARNING: at drivers/gpu/drm/i915/intel_pm.c:4399 __gen6_gt_wait_for_fifo+0x7e/0x90 [i915]()
[abrt] WARNING: at drivers/gpu/drm/i915/intel_pm.c:4399 __gen6_gt_wait_for_fi...
Status: CLOSED DUPLICATE of bug 970958
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
abrt_hash:741a8ceb0612488b237b64c403b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 04:56 EDT by Gabriele Svelto
Modified: 2014-05-21 13:36 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-21 13:36:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (267.26 KB, text/plain)
2013-07-25 04:56 EDT, Gabriele Svelto
no flags Details

  None (edit)
Description Gabriele Svelto 2013-07-25 04:56:43 EDT
Description of problem:
I'm not exactly sure what triggered the bug but I was doing some heavy browsing (I had just opened 10 tabs in a row in Firefox) with the machine already under full load from a heavy compilation job.

Additional info:
reporter:       libreport-2.1.5
WARNING: at drivers/gpu/drm/i915/intel_pm.c:4399 __gen6_gt_wait_for_fifo+0x7e/0x90 [i915]()
Hardware name: 4236PFG
Modules linked in: tcp_lp fuse ebtable_nat nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_nat nf_nat_ipv6 ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables rfcomm bnep dm_crypt snd_hda_codec_conexant iTCO_wdt iTCO_vendor_support mperf coretemp kvm_intel kvm crc32_pclmul crc32c_intel ghash_clmulni_intel cdc_mbim arc4 microcode joydev i2c_i801 snd_hda_intel cdc_ncm iwldvm cdc_wdm snd_hda_codec usbnet mii snd_hwdep mac80211 cdc_acm snd_seq snd_seq_device uvcvideo btusb bluetooth videobuf2_vmalloc videobuf2_memops videobuf2_core videodev snd_pcm media iwlwifi snd_page_alloc sdhci_pci cfg80211 sdhci mmc_core e1000e snd_timer lpc_ich mfd_core ptp mei pps_core thinkpad_acpi snd soundcore rfkill tpm_tis tpm tpm_bios uinput nouveau i915 mxm_wmi ttm i2c_algo_bit drm_kms_helper drm i2c_core wmi video cryptoloop
Pid: 604, comm: Xorg Not tainted 3.9.9-302.fc19.x86_64 #1
Call Trace:
 [<ffffffff8105cc56>] warn_slowpath_common+0x66/0x80
 [<ffffffff8105cd2a>] warn_slowpath_null+0x1a/0x20
 [<ffffffffa01347de>] __gen6_gt_wait_for_fifo+0x7e/0x90 [i915]
 [<ffffffffa00e92a5>] i915_write32+0x165/0x1c0 [i915]
 [<ffffffffa0138b55>] gen6_ring_put_irq+0x75/0xe0 [i915]
 [<ffffffffa00f9be0>] __wait_seqno+0x380/0x510 [i915]
 [<ffffffff81081050>] ? wake_up_bit+0x30/0x30
 [<ffffffffa00fa770>] i915_wait_seqno+0x70/0xa0 [i915]
 [<ffffffffa00faaea>] i915_gem_object_wait_rendering+0x4a/0x80 [i915]
 [<ffffffffa00fbe77>] i915_gem_object_set_to_gtt_domain+0x47/0x160 [i915]
 [<ffffffffa00fd7ba>] i915_gem_pwrite_ioctl+0x28a/0x900 [i915]
 [<ffffffffa003cce5>] ? drm_mode_cursor_common+0xa5/0x170 [drm]
 [<ffffffffa00312c9>] drm_ioctl+0x4e9/0x5b0 [drm]
 [<ffffffffa00fd530>] ? i915_gem_object_unpin+0x50/0x50 [i915]
 [<ffffffff810721ec>] ? signal_setup_done+0x3c/0x60
 [<ffffffff814a3ecc>] ? input_event_to_user+0x5c/0x90
 [<ffffffff8101d37d>] ? __restore_xstate_sig+0x8d/0x510
 [<ffffffff811ab495>] do_vfs_ioctl+0x305/0x520
 [<ffffffff8129495e>] ? file_has_perm+0x8e/0xa0
 [<ffffffff811ab731>] sys_ioctl+0x81/0xa0
 [<ffffffff8164f319>] system_call_fastpath+0x16/0x1b

Potential duplicate: bug 867798
Comment 1 Gabriele Svelto 2013-07-25 04:56:50 EDT
Created attachment 778139 [details]
File: dmesg
Comment 2 Gabriele Svelto 2013-07-25 05:06:08 EDT
Right after experiencing this my machine reported machine check exceptions being recorded. This is the output of mcelog:

Hardware event. This is not a software error.
MCE 0
CPU 1 THERMAL EVENT TSC c50cc1c431a 
TIME 1374742769 Thu Jul 25 10:59:29 2013
Processor 1 heated above trip temperature. Throttling enabled.
Please check your system cooling. Performance will be impacted
STATUS 8803000b MCGSTATUS 0
MCGCAP c07 APICID 1 SOCKETID 0 
CPUID Vendor Intel Family 6 Model 42
Hardware event. This is not a software error.
MCE 1
CPU 0 THERMAL EVENT TSC c50cc1ca8f2 
TIME 1374742769 Thu Jul 25 10:59:29 2013
Processor 0 heated above trip temperature. Throttling enabled.
Please check your system cooling. Performance will be impacted
STATUS 8803000b MCGSTATUS 0
MCGCAP c07 APICID 0 SOCKETID 0 
CPUID Vendor Intel Family 6 Model 42
Hardware event. This is not a software error.
MCE 2
CPU 0 THERMAL EVENT TSC c50cc45daae 
TIME 1374742769 Thu Jul 25 10:59:29 2013
Processor 0 below trip temperature. Throttling disabled
STATUS 8804000a MCGSTATUS 0
MCGCAP c07 APICID 0 SOCKETID 0 
CPUID Vendor Intel Family 6 Model 42
Hardware event. This is not a software error.
MCE 3
CPU 1 THERMAL EVENT TSC c50cc461f9b 
TIME 1374742769 Thu Jul 25 10:59:29 2013
Processor 1 below trip temperature. Throttling disabled
STATUS 8804000a MCGSTATUS 0
MCGCAP c07 APICID 1 SOCKETID 0 
CPUID Vendor Intel Family 6 Model 42

From what I can tell this should not have an impact besides lowering the CPU's clock - in theory - but it might be that overheating caused something else to malfunction at the same time.
Comment 3 Adam Jackson 2014-05-21 13:36:07 EDT

*** This bug has been marked as a duplicate of bug 970958 ***

Note You need to log in before you can comment on or make changes to this bug.