Bug 988314 - Dist-geo-rep: geo-rep create force returns true even in case of a failure.
Dist-geo-rep: geo-rep create force returns true even in case of a failure.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Avra Sengupta
:
Depends On: 980529
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 05:44 EDT by Avra Sengupta
Modified: 2014-04-17 07:44 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 980529
Environment:
Last Closed: 2014-04-17 07:44:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-07-27 00:32:53 EDT
REVIEW: http://review.gluster.org/5405 (glusterd: Fixing create force issues while it returned true everytime.) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 2 Anand Avati 2013-07-29 07:43:18 EDT
COMMIT: http://review.gluster.org/5405 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 355ff31dff9713319a1d2663e5f8d3d386c1b938
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Thu Jul 25 14:58:46 2013 +0530

    glusterd: Fixing create force issues while it returned true everytime.
    
    Now geo-rep create force will return true if a node is down, and log an
    appropriate message. It will also return true with an appropriate log
    message if the slave verification fails.
    
    However it will not return true if the config file is deleted, ot corrupted,
    so as not to get the state_file's path. It will also fail if the slave url
    is invalid. If the push-pem option is given and
    /var/lib/glusterd/geo-replication/common_secret.pem.pub is not present, then
    also the create force command will fail.
    
    Change-Id: Ie7532a0884ddf9c3008bd30832d171d5b53b540e
    BUG: 988314
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/5405
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 3 Anand Avati 2013-08-07 08:05:10 EDT
REVIEW: http://review.gluster.org/5516 (glusterd/gverigy.sh: Stops session being created with invalid slave details.) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 4 Anand Avati 2013-08-07 10:04:38 EDT
REVIEW: http://review.gluster.org/5516 (glusterd/gverigy.sh: Stops session being created with invalid slave details.) posted (#2) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 5 Anand Avati 2013-08-07 10:19:02 EDT
REVIEW: http://review.gluster.org/5516 (glusterd/gverify.sh: Stops session being created with invalid slave details.) posted (#3) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 6 Anand Avati 2013-08-14 08:18:20 EDT
REVIEW: http://review.gluster.org/5516 (glusterd/gverify.sh: Stops session being created with invalid slave details.) posted (#4) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 7 Anand Avati 2013-08-21 09:47:02 EDT
REVIEW: http://review.gluster.org/5516 (glusterd/gverify.sh: Stops session being created with invalid slave details.) posted (#6) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 8 Anand Avati 2013-08-29 07:25:55 EDT
REVIEW: http://review.gluster.org/5516 (glusterd/gverify.sh: Stops session being created with invalid slave details) posted (#7) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 9 Anand Avati 2013-09-03 06:02:56 EDT
REVIEW: http://review.gluster.org/5516 (glusterd/gverify.sh: Stops session being created with invalid slave details) posted (#8) for review on master by Venky Shankar (vshankar@redhat.com)
Comment 10 Anand Avati 2013-09-04 22:29:58 EDT
COMMIT: http://review.gluster.org/5516 committed in master by Anand Avati (avati@redhat.com) 
------
commit 3bfa0dde137f35d68e7f935ddd562136b4829e21
Author: Venky Shankar <vshankar@redhat.com>
Date:   Wed Aug 7 17:09:17 2013 +0530

    glusterd/gverify.sh: Stops session being created with invalid slave details
    
    create force will fail with proper message, if the ip is not
    reachable, or is unable to fetch slave details.
    
    Change-Id: I44a3ba777b37702ffd0e48e9cb46c51e293327d4
    BUG: 988314
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Signed-off-by: Venky Shankar <vshankar@redhat.com>
    Reviewed-on: http://review.gluster.org/5516
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 11 Niels de Vos 2014-04-17 07:44:18 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.