This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 988341 - Should not create bond when report an error in configuration process
Should not create bond when report an error in configuration process
Status: CLOSED WONTFIX
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: ---
: 3.6.0
Assigned To: Ryan Barry
bugs@ovirt.org
node
:
Depends On:
Blocks: 989446
  Show dependency treegraph
 
Reported: 2013-07-25 07:21 EDT by wanghui
Modified: 2016-02-10 14:40 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 989446 (view as bug list)
Environment:
Last Closed: 2015-09-17 10:53:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error in creating bond (63.60 KB, application/x-gzip)
2013-07-25 07:21 EDT, wanghui
no flags Details

  None (edit)
Description wanghui 2013-07-25 07:21:22 EDT
Created attachment 778220 [details]
error in creating bond

Description of problem:
It should not create bond in Network page when report an error while configuration process failed. And it only create bond button but no option in Available System NICs. So it should not create bond button and let the NIC display.

Version-Release number of selected component (if applicable):
ovirt-node-iso-3.0.0-3.999.999.20130716190656git4e57356.2850.fc18.src.rpm
ovirt-node-3.0.0-3.999.20130716190656git4e57356.fc18.noarch

How reproducible:
100%

Steps to Reproduce:
1. Clear install ovirt-node.
2. Configure network using eth2
3. Create bond0.
   Select eth0, eth2 and apply.
   report error as follows:
   Transaction:Network Interface Configuration
   Checking pre-conditions....
   (1/7) Writing bond master configuration
   (2/7) Writing bond slaves configuration
   An error occurred while applying the changes:
   Bond slave can not be used as primary device
4. Check in Network page.
5. Check in status page.
6. Check ping.

Actual results:
In step4, the eth2 disappeared and it have added 'remove bond1(eth2,eth0)' button.
In step5, the networking status change to Unknown with no ip address.
In step6, it can ping outside.

Expected results:
In step4, it should roll back to the settings before.

Additional info:
Comment 1 Fabian Deutsch 2013-08-07 05:59:05 EDT
We can use the Transaction.Element.abort() method to implement a rollback logic.
Comment 2 Sandro Bonazzola 2014-03-04 04:27:41 EST
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.
Comment 3 Sandro Bonazzola 2014-06-11 03:04:56 EDT
This is an automated message:
oVirt 3.4.2 has been released.
This bug has been re-targeted from 3.4.2 to 3.4.3 since priority or severity were high or urgent.
Comment 4 Sandro Bonazzola 2014-06-11 03:05:31 EDT
This is an automated message:
oVirt 3.4.2 has been released.
This bug has been re-targeted from 3.4.2 to 3.4.3 since priority or severity were high or urgent.
Comment 5 Sandro Bonazzola 2014-07-18 05:43:11 EDT
This is an automated message.
oVirt 3.4.3 has been released while this bug was still open.
The bug has been re-targeted to 3.4.4 accordingly.
Comment 6 Sandro Bonazzola 2014-09-24 04:11:29 EDT
Re-targeting since 3.4.4 has been released and only security/critical fixed will be allowed for 3.4.z. 3.5.0 is also in blockers only phase, so re-targeting to 3.5.1.
Comment 7 Fabian Deutsch 2015-09-17 10:53:22 EDT
This functionality will move to cockpit, where this bug does not apply anymore.

Note You need to log in before you can comment on or make changes to this bug.