Bug 988357 - The nic "eno1" got the ip address when after configure it with "Bridge"
The nic "eno1" got the ip address when after configure it with "Bridge"
Status: CLOSED WONTFIX
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
3.3
Unspecified Unspecified
medium Severity medium
: ---
: 3.5.0
Assigned To: Joey Boggs
bugs@ovirt.org
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 07:58 EDT by haiyang,dong
Modified: 2016-02-10 14:39 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-04 06:46:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attached Screenshot (56.42 KB, image/png)
2013-07-25 07:58 EDT, haiyang,dong
no flags Details

  None (edit)
Description haiyang,dong 2013-07-25 07:58:12 EDT
Created attachment 778237 [details]
attached Screenshot

Description of problem:
Install ovirt-node-iso-3.0.0-5.0.3.vdsm.fc19.iso and Enter into network page and select a nic "eno1" to 
configure it with "DHCP" of ipv4 setting and "Use Bridge".
Then clicking "Save" button to apply the setting, after configure it success, 
then check that the nic "en01" got the ip address when after configure it with "Bridge".
Actually we want the bridge "bren01" get the ip address.

[root@dell-op790-01 admin]# ip address show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether d4:be9:95:61:ca brd ff:ff:ff:ff:ff:ff
    inet 10.66.72.10/23 brd 10.66.73.255 scope global eno1
       valid_lft forever preferred_lft forever
    inet6 fe80:6be9ff:fe95:61ca/64 scope link 
       valid_lft forever preferred_lft forever
3: enp3s2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:1b:21:27:47:0b brd ff:ff:ff:ff:ff:ff
    inet6 fe80::21b:21ff:fe27:470b/64 scope link 
       valid_lft forever preferred_lft forever
9: breno1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN 
    link/ether 00:00:00:00:00:00 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::b452:c1ff:fed7:7d6b/64 scope link 
       valid_lft forever preferred_lft forever
[root@dell-op790-01 admin]# 

Also ipv4 shown "None" in the status page.(status.png)

Version-Release number of selected component (if applicable):
http://resources.ovirt.org/releases/3.3/iso/ovirt-node-iso-3.0.0-5.0.3.vdsm.fc19.iso

        

How reproducible:
100%

Steps to Reproduce:


Actual results:

Expected results:


Additional info:
Comment 1 Fabian Deutsch 2013-11-28 07:37:50 EST
Haiyang,

can you please check if this is still reproducable on 3.0.3?
Comment 2 haiyang,dong 2013-11-29 01:30:22 EST
still could reproduce it in ovirt-node-iso-3.0.3-1.1.fc19.iso
Comment 3 haiyang,dong 2013-11-29 02:21:20 EST
Updated reproduce it steps:
1. Clean install ovirt-node-iso-3.0.3-1.1.fc19.iso 
 
2. Enter into network page and select a nic "eno1" to configure it with "DHCP" of ipv4 setting without selecting "Use Bridge"--nic "en01" got the ip address

3. Enter into network page again and select a nic "eno1" to configure it with "DHCP" of ipv4 setting and selected "Use Bridge"--still nic "en01" got the ip address.

Actually after step 3, we want the bridge "bren01" get the ip address.

no this issue if without step 2.
Comment 4 Sandro Bonazzola 2014-03-04 04:23:00 EST
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.
Comment 5 Sandro Bonazzola 2014-05-08 09:56:34 EDT
This is an automated message.

oVirt 3.4.1 has been released.
This issue has been retargeted to 3.5.0 since it has not been marked as high priority or severity issue, please retarget if needed.
Comment 6 Doron Fediuck 2014-09-04 06:46:47 EDT
Based on Bug 1063951, this option will no longer be available.

Note You need to log in before you can comment on or make changes to this bug.