Bug 988364 - Problem during installation packages. Failed on dependencies
Problem during installation packages. Failed on dependencies
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: glibc (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Carlos O'Donell
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 08:13 EDT by Petr Hracek
Modified: 2016-11-24 11:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-25 09:22:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Hracek 2013-07-25 08:13:36 EDT
Description of problem:
I have installed RHEL-7.0 from date 8.7.2013 and all is working properly.
But when I tried to install packages like gcc, glibc-devel, automake, autoconf, valgrind then it failed on dependency

I think that rebuild would be enough.

Steps to Reproduce:
1. yum install git
2. git clone http://github.com/bkabrda/devassistant.git
3. yum install PyYAML git
4. run command ./da.py c -n mycpp and it failed on dependencies

Actual results:
Packages are not installed at all.

Expected results:
Packages are installed

Additional info:
INFO: Checking for presence of gcc...
INFO: Not found, will install
INFO: Checking for presence of glibc-devel...
INFO: Not found, will install
INFO: Checking for presence of automake...
INFO: Not found, will install
INFO: Checking for presence of autoconf...
INFO: Not found, will install
INFO: Checking for presence of valgrind...
INFO: Not found, will install
INFO: Checking for presence of gdb...
INFO: Found gdb-7.6-32.el7.x86_64
INFO: Checking for presence of strace...
INFO: Found strace-4.8-2.el7.x86_64
INFO: Checking for presence of vim-enhanced...
INFO: Found vim-enhanced-7.3.943-2.el7.x86_64
INFO: Checking for presence of vim-X11...
INFO: Not found, will install
INFO: Resolving dependencies ...
Loaded plugins: langpacks, product-id
Install following packages?
 
1:valgrind-3.8.1-4.el7.x86_64
2:vim-X11-7.3.712-3.el7.x86_64
autoconf-2.69-6.el7.noarch
automake-1.12.2-6.el7.noarch
cpp-4.7.2-8.el7.x86_64
gcc-4.7.2-8.el7.x86_64
glibc-2.16-29.el7.i686
glibc-devel-2.16-29.el7.x86_64
glibc-headers-2.16-29.el7.x86_64
kernel-headers-3.7.0-0.36.el7.x86_64
libgomp-4.7.2-8.el7.i686
libmpc-1.0-2.el7.x86_64
m4-1.4.16-5.el7.x86_64
nss-softokn-freebl-3.14-5.el7.i686
perl-Data-Dumper-2.139-1.el7.x86_64
perl-Test-Harness-3.23-255.el7.noarch
Install following packages? [y/n]
y
[devassistant]$ pkexec yum -y install "libgomp-4.7.2-8.el7.i686" "kernel-headers-3.7.0-0.36.el7.x86_64" "perl-Data-Dumper-2.139-1.el7.x86_64" "perl-Test-Harness-3.23-255.el7.noarch" "glibc-headers-2.16-29.el7.x86_64" "glibc-devel-2.16-29.el7.x86_64" "glibc-2.16-29.el7.i686" "1:valgrind-3.8.1-4.el7.x86_64" "cpp-4.7.2-8.el7.x86_64" "nss-softokn-freebl-3.14-5.el7.i686" "m4-1.4.16-5.el7.x86_64" "autoconf-2.69-6.el7.noarch" "automake-1.12.2-6.el7.noarch" "2:vim-X11-7.3.712-3.el7.x86_64" "libmpc-1.0-2.el7.x86_64" "gcc-4.7.2-8.el7.x86_64"
==== AUTHENTICATING FOR org.freedesktop.policykit.exec ===
Authentication is needed to run `/usr/bin/yum' as the super user
Authenticating as: root
Password:
==== AUTHENTICATION COMPLETE ===
| Loaded plugins: langpacks, product-id, subscription-manager
| This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
| Resolving Dependencies
| --> Running transaction check
| ---> Package autoconf.noarch 0:2.69-6.el7 will be installed
| ---> Package automake.noarch 0:1.12.2-6.el7 will be installed
| ---> Package cpp.x86_64 0:4.7.2-8.el7 will be installed
| ---> Package gcc.x86_64 0:4.7.2-8.el7 will be installed
| ---> Package glibc.i686 0:2.16-29.el7 will be installed
| --> Processing Dependency: glibc-common = 2.16-29.el7 for package: glibc-2.16-29.el7.i686
| ---> Package glibc-devel.x86_64 0:2.16-29.el7 will be installed
| ---> Package glibc-headers.x86_64 0:2.16-29.el7 will be installed
| ---> Package kernel-headers.x86_64 0:3.7.0-0.36.el7 will be installed
| ---> Package libgomp.i686 0:4.7.2-8.el7 will be installed
| ---> Package libmpc.x86_64 0:1.0-2.el7 will be installed
| ---> Package m4.x86_64 0:1.4.16-5.el7 will be installed
| ---> Package nss-softokn-freebl.i686 0:3.14-5.el7 will be installed
| ---> Package perl-Data-Dumper.x86_64 0:2.139-1.el7 will be installed
| ---> Package perl-Test-Harness.noarch 0:3.23-255.el7 will be installed
| ---> Package valgrind.x86_64 1:3.8.1-4.el7 will be installed
| ---> Package vim-X11.x86_64 2:7.3.712-3.el7 will be installed
| --> Processing Dependency: vim-common = 2:7.3.712-3.el7 for package: 2:vim-X11-7.3.712-3.el7.x86_64
| --> Finished Dependency Resolution
| Error: Package: glibc-2.16-29.el7.i686 (rhel-server)
| Requires: glibc-common = 2.16-29.el7
| Installed: glibc-common-2.17-11.el7.x86_64 (@anaconda)
| glibc-common = 2.17-11.el7
| Available: glibc-common-2.16-29.el7.x86_64 (rhel-server)
| glibc-common = 2.16-29.el7
| Error: Package: 2:vim-X11-7.3.712-3.el7.x86_64 (rhel-server)
| Requires: vim-common = 2:7.3.712-3.el7
| Installed: 2:vim-common-7.3.943-2.el7.x86_64 (@anaconda)
| vim-common = 2:7.3.943-2.el7
| Available: 2:vim-common-7.3.712-3.el7.x86_64 (rhel-server)
| vim-common = 2:7.3.712-3.el7
| You could try using --skip-broken to work around the problem
| You could try running: rpm -Va --nofiles --nodigest
Comment 1 Siddhesh Poyarekar 2013-07-25 08:22:06 EDT
Not a bug in glibc.  The repository you're trying to pull from is old.  It tries to install glibc-2.16-29.el7.i686 which is much older than your currently installed glibc (2.17-11.el7).

Either the repos configured in /etc/yum.repos.d are wrong (which may be either a distribution or compose bug) or you've done something wrong.

Note You need to log in before you can comment on or make changes to this bug.