Bug 98846 - typemaps produce odd read() behaviour
typemaps produce odd read() behaviour
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: httpd (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-09 11:10 EDT by Joe Orton
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-12 10:11:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2003-07-09 11:10:24 EDT
httpd-2.0.46-7.ent

strace of an httpd which reads a typemap produces this weird output:

open("/var/www/error/HTTP_BAD_REQUEST.html.var", O_RDONLY) = 14
read(14, "Content-language: cs\nContent-typ"..., 4096) = 3967
read(14, "", 4096)                      = 0
read(14, "", 4096)                      = 0
read(14, "", 4096)                      = 0
read(14, "", 4096)                      = 0
read(14, "", 4096)                      = 0
read(14, "", 4096)                      = 0
read(14, "", 4096)                      = 0
read(14, "", 4096)                      = 0
read(14, "", 4096)                      = 0
read(14, "", 4096)                      = 0
read(14, "", 4096)                      = 0
Comment 1 Joe Orton 2005-09-12 10:11:31 EDT
This is probably caused by the apr_file_gets() implementation in APR 0.9.x; it
should be fixed in APR 1.2.x.

Note You need to log in before you can comment on or make changes to this bug.