Bug 988487 - Unable to appropriately change base channel of registered Red Hat Storage (RHS) 2.0 server, for upgrade to RHS 2.1, using Red Hat Satellite server UI
Unable to appropriately change base channel of registered Red Hat Storage (RH...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: distribution (Show other bugs)
2.0
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Anthony Towns
Sachidananda Urs
:
: 961625 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 12:57 EDT by Rejy M Cyriac
Modified: 2014-07-11 02:40 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:32:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rejy M Cyriac 2013-07-25 12:57:59 EDT
Description of problem:
As part of the upgrade process of an RHS 2.0 server to RHS 2.1 , through Red Hat (RH) Satellite server, it is required to change the registered base channel from 'rhel-x86_64-server-6.2.z' to 'rhel-x86_64-server-6.4.z' . If this is attempted using the 'Alter Channel Subscriptions' link on the system details page, at the RH Satellite administration UI, only the 'rhel-x86_64-server-6' base channel' , and 'none, disable service' is shown in the 'Base Software Channel' options box. So it is not possible to have the RHS server subscribed to 'rhel-x86_64-server-6.4.z' base channel. This blocks the upgrade process.

But if a stock RHEL 6 system is registered to RH Satellite server, it is possible to alter the base channel subscription from 'rhel-x86_64-server-6' to any of the RHEL 6 EUS base channels.

Version-Release number of selected component (if applicable):
RHS 2.0 (Update 5)
RHS 2.1
RH Satellite server 5.5

How reproducible:
Always Reproducible

Steps to Reproduce:
1. Install RHS 2.0 server, and register to RH Satellite server
2. The RHS 2.0 server is automatically subscribed to 'rhel-x86_64-server-6.2.z' channel
3. Login to the RH Satellite administration UI , and attempt to change the base channel subscription of the RHS 2.0 server to 'rhel-x86_64-server-6.4.z'

Actual results:
It is not possible to alter the base channel subscription of an RHS 2.0 server from 'rhel-x86_64-server-6.2.z' to 'rhel-x86_64-server-6.4.z' , at RH Satellite server administration UI, which is required for the upgrade process of RHS 2.0 to RHS 2.1.

Expected results:
It should be possible to alter the base channel subscription of an RHS 2.0 server from 'rhel-x86_64-server-6.2.z' to 'rhel-x86_64-server-6.4.z' , at RH Satellite server administration UI, as this is required for the upgrade process of RHS 2.0 to RHS 2.1.

Additional info:

By using a combination of activation key associated with 'rhel-x86_64-server-6.4.z', and the 'rhnreg_ks' command, it is possible to force this change, from the command line, on the RHS 2.0 server. However this will result in the RHS server getting a new 'System ID' and profile at the RH Satellite server, and the old profile has to be manually deleted.
Comment 6 Anthony Towns 2013-08-08 22:56:33 EDT
*** Bug 961625 has been marked as a duplicate of this bug. ***
Comment 7 Sachidananda Urs 2013-08-12 05:35:49 EDT
We are blocked testing upgrade using satellite. Fixing this ASAP gives some time to test satellite upgrade scenario.
Comment 8 Sayan Saha 2013-08-12 17:16:02 EDT
Guys,

You are doing this wrong. You need to first disable the base channel and then re-subscribe from the UI. You can't directly re-subscribe to another base channel from the RHN UI.
Comment 10 Rejy M Cyriac 2013-08-13 15:42:15 EDT
(In reply to Sayan Saha from comment #8)
> Guys,
> 
> You are doing this wrong. You need to first disable the base channel and
> then re-subscribe from the UI. You can't directly re-subscribe to another
> base channel from the RHN UI.

The "disable" work around was tested earlier, and had been found not to
work for RHS server + RH Satellite server. Based on the discussion around this, I have re-tested it.

The result is that the "disable" work around *does not* work for RHS
server registered to RH Satellite server, but *does work* for the same
RHS server registered to RHN.

And surprisingly, when the same process is tried using a pure RHEL 6.2
system, the "disable" work around does work for it when registered to RH Satellite server, just as it works when registered to RHN.
Comment 12 Sayan Saha 2013-08-20 14:32:36 EDT
Since Red Hat Satellite Server integration was not supported before 2.1, ability to upgrade using satellite is not expected to be delivered in the 2.1 release. Release engineering should still investigate this problem with a high priority but this does not qualify as a blocker.
Comment 15 Sachidananda Urs 2013-08-21 07:42:45 EDT
Verified:

[root@u5-1 ~]# ./rhs_upgrade.py --username=qa@redhat.com
--password=redhatqa --rhs-version=2.1
Subscribed to channel rhel-x86_64-server-sfs-6.4.z
Subscribed to channel rhel-x86_64-server-6-rhs-2.1
[root@u5-1 ~]# rhn-channel -l
rhel-x86_64-server-6-rhs-2.1
rhel-x86_64-server-6.4.z
rhel-x86_64-server-sfs-6.4.z
[root@u5-1 ~]#
Comment 16 Scott Haines 2013-09-23 18:32:15 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.