Bug 988530 - KickstartValueError: The following problem occurred on line 23 of the kickstart file: Tried to use undefined partition pv.1 in Volume Group specification
KickstartValueError: The following problem occurred on line 23 of the kicksta...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:2060d3cb3e06e3c6f283229f552...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 15:10 EDT by David Caro
Modified: 2016-06-26 19:50 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 13:48:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dshea: needinfo-


Attachments (Terms of Use)
File: anaconda-tb (305.78 KB, text/plain)
2013-07-25 15:10 EDT, David Caro
no flags Details
File: anaconda.log (5.49 KB, text/plain)
2013-07-25 15:10 EDT, David Caro
no flags Details
File: environ (589 bytes, text/plain)
2013-07-25 15:10 EDT, David Caro
no flags Details
File: ks.cfg (1.39 KB, text/plain)
2013-07-25 15:10 EDT, David Caro
no flags Details
File: lsblk_output (948 bytes, text/plain)
2013-07-25 15:10 EDT, David Caro
no flags Details
File: nmcli_dev_list (32.29 KB, text/plain)
2013-07-25 15:10 EDT, David Caro
no flags Details
File: os_info (179 bytes, text/plain)
2013-07-25 15:10 EDT, David Caro
no flags Details
File: program.log (63.65 KB, text/plain)
2013-07-25 15:11 EDT, David Caro
no flags Details
File: storage.log (81.42 KB, text/plain)
2013-07-25 15:11 EDT, David Caro
no flags Details
File: syslog (170.88 KB, text/plain)
2013-07-25 15:11 EDT, David Caro
no flags Details
File: ifcfg.log (3.04 KB, text/plain)
2013-07-25 15:11 EDT, David Caro
no flags Details
File: packaging.log (2.10 KB, text/plain)
2013-07-25 15:11 EDT, David Caro
no flags Details
screenshot showing KickstartValueError exception in text mode (15.93 KB, image/png)
2013-07-26 10:49 EDT, Steve Tyler
no flags Details
screenshot showing "('new lv is too large to fit in free space', 'vg0')" warning (13.72 KB, image/png)
2013-07-26 10:51 EDT, Steve Tyler
no flags Details
anaconda-tb-uP3J7o from reproducer in Comment 16 (198.80 KB, text/plain)
2013-07-26 11:01 EDT, Steve Tyler
no flags Details

  None (edit)
Description David Caro 2013-07-25 15:10:01 EDT
Description of problem:
installing on a fresh vm from pxe boot as text mode

Version-Release number of selected component:
anaconda-19.30.13-1

The following was filed automatically by anaconda:
anaconda 19.30.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1334, in execute
    raise KickstartValueError, formatErrorMsg(self.lineno, msg="Tried to use undefined partition %s in Volume Group specification" % pv)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1313, in execute
    v.execute(storage, ksdata, instClass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1647, in doKickstartStorage
    ksdata.volgroup.execute(storage, ksdata, instClass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/spokes/storage.py", line 253, in execute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/spokes/storage.py", line 203, in input
    self.execute()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 441, in input
    key = self._screens[-1][0].input(args, key)
KickstartValueError: The following problem occurred on line 23 of the kickstart file:

Tried to use undefined partition pv.1 in Volume Group specification


Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=/images/Fedora19-x86_64/initrd.img ksdevice=bootif lang=  kssendmac text  ks=http://10.35.16.92/cblr/svc/op/ks/profile/Fedora19-x86_64 BOOTIF=01-00-1a-4a-43-d9-50 BOOT_IMAGE=/images/Fedora19-x86_64/vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19
Comment 1 David Caro 2013-07-25 15:10:07 EDT
Created attachment 778463 [details]
File: anaconda-tb
Comment 2 David Caro 2013-07-25 15:10:13 EDT
Created attachment 778464 [details]
File: anaconda.log
Comment 3 David Caro 2013-07-25 15:10:17 EDT
Created attachment 778465 [details]
File: environ
Comment 4 David Caro 2013-07-25 15:10:21 EDT
Created attachment 778466 [details]
File: ks.cfg
Comment 5 David Caro 2013-07-25 15:10:25 EDT
Created attachment 778467 [details]
File: lsblk_output
Comment 6 David Caro 2013-07-25 15:10:30 EDT
Created attachment 778468 [details]
File: nmcli_dev_list
Comment 7 David Caro 2013-07-25 15:10:54 EDT
Created attachment 778469 [details]
File: os_info
Comment 8 David Caro 2013-07-25 15:11:00 EDT
Created attachment 778470 [details]
File: program.log
Comment 9 David Caro 2013-07-25 15:11:04 EDT
Created attachment 778471 [details]
File: storage.log
Comment 10 David Caro 2013-07-25 15:11:09 EDT
Created attachment 778472 [details]
File: syslog
Comment 11 David Caro 2013-07-25 15:11:13 EDT
Created attachment 778473 [details]
File: ifcfg.log
Comment 12 David Caro 2013-07-25 15:11:17 EDT
Created attachment 778474 [details]
File: packaging.log
Comment 13 Steve Tyler 2013-07-26 00:38:58 EDT
The attached ks.cfg has:
part  pv.1 --grow --size=1

A kickstart file generated by anaconda has an '--fstype="lvmpv"' option:
part pv.5 --fstype="lvmpv" --noformat --onpart=sda5

The Installation Guide doesn't mention "lvmpv", however:
http://docs.fedoraproject.org/en-US/Fedora/19/html/Installation_Guide/s1-kickstart2-options.html
Comment 14 Steve Tyler 2013-07-26 04:03:21 EDT
I can't reproduce this exception in graphical mode. The installer always halts in the Installation Summary with a "No disk selected" error.

Procedure:

Configure the attached ks.cfg to use kernel.org or cdrom as a source:
url --url=http://mirrors.kernel.org/fedora/releases/19/Fedora/x86_64/os/
#cdrom

# Initialize a 2 GB disc image -- size is per attached storage.log:
$ qemu-img create f19-test-3.img 2G

Start the F19 DVD installer in a VM:
$ qemu-kvm -m 4096 -hda f19-test-3.img -cdrom ~/xfr/fedora/F19/Fedora-19-x86_64-DVD.iso -vga std -boot menu=on

Specify the NFS server and host path to the kickstart file on the kernel command-line.

NB: If the disc size is increased to 12 GB, the install succeeds.
    I commented out the wget at the end.
    The redhat.com server in the attached ks.cfg is not accessible.
Comment 15 Steve Tyler 2013-07-26 09:50:54 EDT
Can you reproduce this using an external server?
The server in the attached ks.cfg is not accessible:

$ curl -I http://download.eng.tlv.redhat.com/pub/fedora/linux/releases/19/Fedora/x86_64/os/
curl: (6) Could not resolve host: download.eng.tlv.redhat.com; Name or service not known
Comment 16 Steve Tyler 2013-07-26 10:49:37 EDT
Created attachment 778789 [details]
screenshot showing KickstartValueError exception in text mode

I reproduced this in text mode. The installer lets you continue after this warning:
('new lv is too large to fit in free space', 'vg0')

Procedure:

Use cdrom for source in kickstart file.
$ qemu-img create f19-test-3.img 2G
$ qemu-kvm -m 1024 -drive if=virtio,file=f19-test-3.img -cdrom ~/xfr/fedora/F19/Fedora-19-x86_64-DVD.iso -vga std -boot menu=on
Start installer in text mode with kickstart file on NFS server specified.

Press 3 to select Install Destination.
This warning is displayed:
('new lv is too large to fit in free space', 'vg0')

Press 1 to select vda.
The warning is repeated.
Press 'c' to continue.
Press 'c' to continue.
Press 'c' to continue.

KickstartValueError exception occurs with the message:
"Tried to use undefined partition pv.1 in Volume Group specification"
An option to report a bug is displayed.
Comment 17 Steve Tyler 2013-07-26 10:51:12 EDT
Created attachment 778791 [details]
screenshot showing "('new lv is too large to fit in free space', 'vg0')" warning
Comment 18 Steve Tyler 2013-07-26 11:01:33 EDT
Created attachment 778793 [details]
anaconda-tb-uP3J7o from reproducer in Comment 16
Comment 19 David Shea 2013-08-01 13:48:23 EDT
The kickstart has 2.1G worth of logical volumes (+500M /boot) on a 2G disk.
Comment 20 Steve Tyler 2013-08-02 17:00:37 EDT
This bug should be reopened, because the installer is allowing the user to continue after what should have been a fatal error. See Comment 16.

The installer should exit after displaying the message:
('new lv is too large to fit in free space', 'vg0')
Comment 21 Steve Tyler 2013-08-02 17:02:47 EDT
Please reopen per Comment 20, Comment 16.

Note You need to log in before you can comment on or make changes to this bug.