Bug 988611 - Infinitely recursive Packages link in published repositories.
Infinitely recursive Packages link in published repositories.
Status: CLOSED NOTABUG
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
2.2 Beta
All Unspecified
unspecified Severity low
: ---
: 2.2.0
Assigned To: Jason Connor
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 20:09 EDT by Ryan Bowlby
Modified: 2014-03-30 21:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 10:55:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Bowlby 2013-07-25 20:09:20 EDT
Description of problem:

Pulp repositories with no origin (where pulp is the origin) have a "Packages" directory and repodata directory. Clicking on the Packages directory sends you back to the same directory only the URL in the browser is now one deeper, e.g.

http://pulpserver/pulp/repos/prod-thirdparty/Packages/Packages/Packages/Packages/

Version-Release number of selected component (if applicable):

2.2.0-0.20.beta.el6

How reproducible:

All locally created repos experience this issue.

r='prod-thirdparty'

Steps to Reproduce:
1.pulp-admin rpm repo create --repo-id=${r} --display-name=${r} --relative-url=${r} --serve-http=true --serve-https=true --checksum-type=sha1
2.pulp-admin rpm repo publish run --repo-id $r
3. view published dir

Actual results:


Expected results:


Additional info:
Comment 1 Jason Connor 2013-08-29 10:55:49 EDT
This is by design and is required by RHEL 5 kickstart trees. Diagnosis: don't following the link

Note You need to log in before you can comment on or make changes to this bug.