Bug 988707 - MOUNT_UNDER_SCRATCH=/home disable access to other directories
MOUNT_UNDER_SCRATCH=/home disable access to other directories
Status: CLOSED WONTFIX
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor (Show other bugs)
Development
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: grid-maint-list
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-26 03:59 EDT by Martin Kudlej
Modified: 2016-05-26 15:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-26 15:29:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kudlej 2013-07-26 03:59:15 EDT
Description of problem:
I've set MOUNT_UNDER_SCRATCH=/home and simple job:
cmd=/bin/ls
queue

is not working because 
$ condor_q -bet 
...
051.000:  Request is held.

Hold reason: Error from _hostname_: Failed to execute '/bin/ls': (errno=2: 'No such file or directory')

I've tried different binaries(for example /usr/bin/python) with same result.

If I've set MOUNT_UNDER_SCRATCH=/home/test #test is name of user who submits jobs
everything works.

I think MOUNT_UNDER_SCRATCH=/home is valid case which can be used for isolation of home directories.


Version-Release number of selected component (if applicable):
condor-7.8.8-0.4.3

How reproducible:
100%

Actual results:
I's not possible to run any binaries outside of home directory(for example /bin/ls) when MOUNT_UNDER_SCRATCH=/home

Expected results:
I will be possible to run any binaries outside of home directory(for example /bin/ls) when MOUNT_UNDER_SCRATCH=/home

Additional info:
Disk structure(it is obvious that /home is on same partition as /):
   Device Boot      Start         End      Blocks   Id  System
/dev/vda1   *           1         575     4618656   83  Linux
/dev/vda2             576         651      610470   82  Linux swap / Solaris
Comment 1 Anne-Louise Tangring 2016-05-26 15:29:41 EDT
MRG-Grid is in maintenance and only customer escalations will be considered. This issue can be reopened if a customer escalation associated with it occurs.

Note You need to log in before you can comment on or make changes to this bug.