Bug 988721 - qemu-img core dump when creating 1EB qcow2 disk
qemu-img core dump when creating 1EB qcow2 disk
Status: CLOSED DUPLICATE of bug 1079320
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Kevin Wolf
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-26 04:49 EDT by juzhang
Modified: 2014-04-23 09:17 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-23 09:17:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description juzhang 2013-07-26 04:49:22 EDT
Description of problem:
qemu-img core dump when creating 1EB qcow2 disk

Version-Release number of selected component (if applicable):
qemu-img-1.5.1-2.el7.x86_64
qemu-kvm-1.5.1-2.el7.x86_64
#uname -r
3.10.0-0.rc7.64.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.#qemu-img create -f qcow2 -o compat=1.1 test.qcow2v3 1024000T
2.
3.

Actual results:
qemu-img create -f qcow2 -o compat=1.1 test.qcow2v3 1024000T
Formatting 'test.qcow2v3', fmt=qcow2 size=1125899906842624000 compat='1.1' encryption=off cluster_size=65536 lazy_refcounts=off 

(process:8744): GLib-ERROR **: gmem.c:195: failed to allocate 18446744073306898432 bytes
Trace/breakpoint trap (core dumped)


Expected results:
Image can be created

Additional info:
(gdb) bt
#0  0x00007ffff76f4e0d in g_logv () from /lib64/libglib-2.0.so.0
#1  0x00007ffff76f4ff2 in g_log () from /lib64/libglib-2.0.so.0
#2  0x00007ffff76f392c in g_malloc0 () from /lib64/libglib-2.0.so.0
#3  0x0000555555572caa in qcow2_grow_l1_table (bs=bs@entry=0x555555bfad70, min_size=min_size@entry=2097152000, exact_size=exact_size@entry=true)
    at block/qcow2-cluster.c:67
#4  0x0000555555578bf8 in qcow2_truncate (bs=0x555555bfad70, offset=1125899906842624000) at block/qcow2.c:1512
#5  0x0000555555562fac in bdrv_truncate (bs=0x555555bfad70, offset=offset@entry=1125899906842624000) at block.c:2677
#6  0x0000555555578f5a in qcow2_create2 (version=<optimized out>, options=<optimized out>, prealloc=<optimized out>, cluster_size=65536, 
    flags=<optimized out>, backing_format=0x0, backing_file=0x0, total_size=2199023255552000, filename=0x555555bf9b10 "test.qcow2v3") at block/qcow2.c:1339
#7  qcow2_create (filename=0x555555bf9b10 "test.qcow2v3", options=<optimized out>) at block/qcow2.c:1431
#8  0x0000555555560f4b in bdrv_create_co_entry (opaque=0x7fffffffe300) at block.c:367
#9  0x00005555555927aa in coroutine_trampoline (i0=<optimized out>, i1=<optimized out>) at coroutine-ucontext.c:118
#10 0x00007ffff68da590 in ?? () from /lib64/libc.so.6
#11 0x00007fffffffdb60 in ?? ()
#12 0x0000000000000000 in ?? ()
Comment 2 Kevin Wolf 2014-04-23 09:17:15 EDT
This was fixed with one of the block audit patches, closing.

*** This bug has been marked as a duplicate of bug 1079320 ***

Note You need to log in before you can comment on or make changes to this bug.