Bug 988798 - networkmanager-openvpn broken after yum update
networkmanager-openvpn broken after yum update
Status: CLOSED DUPLICATE of bug 988131
Product: Fedora
Classification: Fedora
Component: NetworkManager-openvpn (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-07-26 08:14 EDT by domgross
Modified: 2013-07-26 10:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-07-26 10:09:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description domgross 2013-07-26 08:14:24 EDT
I am new to Fedora, so I am not 100% sure where this goes, but this looks like a bug to me:

Installed F19 via live ISO a couple of days ago and openvpn via networkmanager worked fine. After yum update openvpn support was almost fully gone. 

Original version:
    Install     NetworkManager-openvpn-1:                                   @koji-override-0/$releasever
    Dep-Install openvpn-2.3.2-1.fc19.x86_64                                                      @koji-override-0/$releasever

yum update resulted in an update from: NetworkManager-openvpn-1: @koji-override-0/$releasever to: NetworkManager-openvpn-1: @updates

In that state I could still connect using previously defined openvpn profiles, but everything else was broken, i.e. Openvpn (and cisco) were missing from the "Add Network Connection" Dialog, when trying to edit settings for a previously configured openvpn profile nm showed: "unable to load vpn connection editor". 

Installing NetworkManager-openvpn-gnome-1: @updates fixed the issue.
Comment 1 Dan Williams 2013-07-26 10:09:30 EDT

*** This bug has been marked as a duplicate of bug 988131 ***

Note You need to log in before you can comment on or make changes to this bug.