Bug 988829 - [RFE] Option to shut qemu/kvm guests down cleanly instead of saving on hypervisor shutdown
[RFE] Option to shut qemu/kvm guests down cleanly instead of saving on hyperv...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
All Linux
medium Severity medium
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-26 09:51 EDT by Allan Voss
Modified: 2013-12-05 03:19 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-28 09:54:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allan Voss 2013-07-26 09:51:42 EDT
1. Proposed title of this feature request
Option to shut qemu/kvm guests down cleanly instead of saving on hypervisor shutdown

3. What is the nature and description of the request?
Currently, VMs are paused and saved when the hypervisor is shutdown. The option to shut down the guests cleanly (e.g. ACPI shutdown) instead of pausing them is desired.

4. Why does the customer need this? (List the business requirements here)
"We would like to be able to reboot a hypervisor and have its KVM's shutdown cleanly and have them restart on boot(as opposed to having their state suspended). Windows hosts can sometimes act strange if they've been up for a while. When hypervisors get rebooted you can end up w/ various windows KVM's having long uptimes without knowing it. Also, you're more prone to having corruption of the filesystem due to the suspend requirements of space in /var. If /var free space is too low, the suspend fails."

5. How would the customer like to achieve this? (List the functional
requirements here)
When hypervisor shutdown commences, send ACPI shutdown command to all running guests. Once guests are no longer running, continue shutdown process.

6. For each functional requirement listed in question 5, specify how Red Hat
and the customer can test to confirm the requirement is successfully
implemented.
Start VMs. Shutdown hypervisor. Check guests on restart for clean shutdown.

7. Is there already an existing RFE upstream or in Red Hat bugzilla?
No

8. Does the customer have any specific timeline dependencies?
No

9. Is the sales team involved in this request and do they have any additional input?
No

10. List any affected packages or components.
kvm, libvirt

11. Would the customer be able to assist in testing this functionality if
implemented?
Yes
Comment 3 Andrew Cathrow 2013-07-28 09:54:59 EDT
This functionality is present in libvirt-guests service, although documentation seems to be lacking  for it - which we'll address in a separate BZ.

Note You need to log in before you can comment on or make changes to this bug.