Bug 988830 - Cannot start a process instance in BPMS DR6 in business central gui
Cannot start a process instance in BPMS DR6 in business central gui
Status: CLOSED WORKSFORME
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Mauricio Salatino
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-26 09:56 EDT by Jiri Svitak
Modified: 2015-06-01 21:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 10:56:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log (42.16 KB, text/plain)
2013-07-26 09:56 EDT, Jiri Svitak
no flags Details

  None (edit)
Description Jiri Svitak 2013-07-26 09:56:13 EDT
Created attachment 778772 [details]
server.log

To reproduce:

1.) Merge eap6 with bpms 6 DR6 deployable
2.) Add user guest, password guest, to ease that use:
guest=b5d048a237bfd2874b6928e1f37ee15e   # application-users.properties
guest=guest,kie-user                     # application-roles.properties
3.) Clone QE testing bpms-assets git repo from
https://code.engineering.redhat.com/gerrit/gitweb?p=bpms-assets.git;a=summary
4.) Start the server ./standalone.sh (I've changed web.xml to BASIC auth, but that is optional)
5.) Login, click on Authoring->Administration, then Repository->Clone
6.) Fill the clone repository form - name 'bpms-assets, group 'demo', location of your previously cloned bpms-assets repo on the disc.
7.) Click Authoring->Project Authoring, then Tools->Project Editor, click on Build & deploy
8.) Open Process definitions tab and start for example 'Start End' process

Issue: The gui does nothing. Form with large start arrow stays there, you would expect that the form closes and you are informed that the process started. Exception is thrown in server log, see the attachment. Root cause seems to be:
Caused by: org.h2.jdbc.JdbcSQLException: NULL not allowed for column "PK"; SQL statement:
15:25:37,531 ERROR [stderr] (http-/127.0.0.1:8080-6) insert into ProcessInstanceLog (id, duration, end_date, externalId, user_identity, outcome, parentProcessInstanceId, processId, processInstanceId, processName, processVersion, start_date, status) values (null, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?) [23502-168]

Also another exception is generated later:
RuntimeException: no marshalling definition available for type:javax.persistence.PersistenceException

It seems that PersistenceException should be marshalled as well. Tell me if I should file second bugzilla for this marshalling exception.

The expected behavior of starting processes should be that the process has either started or proper error is shown in gui, why the process cannot be started.
Comment 1 Mauricio Salatino 2013-07-26 10:09:34 EDT
What is the 'Start End' doing? 
Did you tried with your own process? I believe that 'Start End' is just an integration test used for develop the application and it shouldn't be used to test the app, because I cannot guarantee that it's working correctly. Please test with your own processes. You can try HR and Evaluation that are supposed to be working.
Comment 2 Jiri Svitak 2013-07-26 10:22:56 EDT
'Start End' is just Start->End bpmn2 process, on of the simplest ones. It's my own process from bpms-perf project of QE's bpms-assets repo. So it's not an integration test.

It's ID is com.bpms.flood.StartEnd. If the process name 'Start End' is reserved, it should be documented, or BPMS should inform that during deployment of the unit.

I have tried also my two other process from the bpms-perf project - com.bpms.flood.HumanTask and com.bpms.flood.Timer with the same exception.

If you are not able to reproduce the exception, please try the steps from the post above, or ping me on irc.
Comment 3 Jiri Svitak 2013-07-26 13:31:49 EDT
I have reused the same eap instance. Everytime I delete data from the last run:
cd jboss-eap-6.1/bin
rm -rf .index .niogit repository
cd jboss-eap-6.1/standalone
rm -rf log tmp data

I have also tried setup the bpms from scratch, but I experience the same issue with DR6.
Comment 4 Jiri Svitak 2013-07-26 15:44:33 EDT
After further investigation, something seems to be corrupted in my environment. I have installed fresh jbpm 6 cr1 on top of eap 6.1 and I see the following in the server log:
21:32:15,811 ERROR [org.drools.core.xml.ExtensibleXmlParser] (MSC service thread 1-1) (null: 21, 142): cvc-datatype-valid.1.2.1: 'platform:/resource/bpms-6.x/src/main/resources/Timer.bpmn2#com.bpms.flood.Timer' is not a valid value for 'QName'.

It seems that some artifacts were installed in my system .m2 repository as I can see in server.log:
21:32:16,144 INFO  [org.drools.compiler.kie.builder.impl.KieRepositoryImpl] (MSC service thread 1-1) KieModule was added:ZipKieModule[ ReleaseId=com.bpms.flood:bpms-perf:1.0.0.Finalfile=/home/jsvitak/.m2/repository/com/bpms/flood/bpms-perf/1.0.0.Final/bpms-perf-1.0.0.Final.jar]

I am going to purge my repository and try the steps to reproduce again. What else I need to remove besides the bpms/eap dir and jars in m2 repo to get bpms installation to default state?
Comment 5 Jiri Svitak 2013-07-31 10:56:43 EDT
So after further investigation I've reported two new bugs:
https://bugzilla.redhat.com/show_bug.cgi?id=990575
https://bugzilla.redhat.com/show_bug.cgi?id=990580

After the full cleanup of my system including system /tmp dir and old artifacts in local .m2 repository I was able to start process instances and see them completed.

Simple Start->End process worked fine, but another simple process Start->HumanTask->End completed fine, but threw transaction exceptions when working with its human task, see:
https://bugzilla.redhat.com/show_bug.cgi?id=990620

Closing this bug, as under good conditions I am able to start a proces instance in CR1. I have stopped to use DR6, but I hope that's ok and does not affect this bugzilla.


Tested env:
EAP 6.1
jBPM 6 CR1
H2

Note You need to log in before you can comment on or make changes to this bug.