Bug 988852 - Dist-geo-rep : geo rep status should show detail info. like file count, byte counts, replicated and remaining. files deleted & remaining
Dist-geo-rep : geo rep status should show detail info. like file count, byte ...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
urgent Severity high
: ---
: ---
Assigned To: Avra Sengupta
amainkar
: TestBlocker
Depends On:
Blocks: 990420
  Show dependency treegraph
 
Reported: 2013-07-26 10:51 EDT by Rachana Patel
Modified: 2015-04-20 07:57 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.15rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 990420 (view as bug list)
Environment:
Last Closed: 2013-09-23 18:29:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rachana Patel 2013-07-26 10:51:41 EDT
Description of problem:
 Display sync status of selected geo-replication relationships, including dynamically updated file counts and byte counts replicated on this pass and remaining to replicate. Also files deleted and remaining files to delete. GUI should have appropriate sca

Version-Release number of selected component (if applicable):
3.4.0.12rhs.beta6-1.el6rhs.x86_64


How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
status is not showing any of this information

Expected results:


Additional info:
Comment 4 M S Vishwanath Bhat 2013-08-08 06:39:35 EDT
I can see details like files synced, files pending, bytes pending and deletes pending.

                                        MASTER: master  SLAVE: riemann::slave
 
NODE                           HEALTH    UPTIME      FILES SYNCD    FILES PENDING    BYTES PENDING    DELETES PENDING   
----------------------------------------------------------------------------------------------------------------------
pythagoras.blr.redhat.com      Stable    01:08:28    1              59               919.7KB          0                 
ramanujan.blr.redhat.com       Stable    01:08:26    0              0                0Bytes           0                 


We need to properly document what each of those columns (files synced, files pending etc). For example files pending is always a increasing count. If a file is deleted, this will not come down. Things like these should be documented.

Moving to VERIFIED since it shows those options now.
Comment 5 Scott Haines 2013-09-23 18:29:51 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.