Bug 988853 - Review Request: libevent2 - Abstract asynchronous event notification library [EPEL]
Review Request: libevent2 - Abstract asynchronous event notification library ...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-26 10:52 EDT by Remi Collet
Modified: 2013-07-26 10:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-26 10:54:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Remi Collet 2013-07-26 10:52:04 EDT
Spec URL: https://raw.github.com/remicollet/remirepo/dfb34699909a5b26f240d44a18cc1e7f2c2f938e/libevent2/libevent2.spec
SRPM URL: http://rpms.famillecollet.com/SRPMS/libevent2-2.0.18-1.remi.src.rpm
Description: 
The libevent API provides a mechanism to execute a callback function
when a specific event occurs on a file descriptor or after a timeout
has been reached. libevent is meant to replace the asynchronous event
loop found in event driven network servers. An application just needs
to call event_dispatch() and can then add or remove events dynamically
without having to change the event loop.

Fedora Account System Username: remi

This package is only for EPEL (fedora already have version 2.0).
libevent2 can be installed beside libevent (no conflicts)
libevent2-devel cannot (allowed by Guidelines, "compat" case)

I prefer to submit version 2.0.18 (as in fedora), and will update to last version (2.0.21) later (currently FTBFS in rawhide). ABI is stable according to http://upstream-tracker.org/versions/libevent.html
Comment 1 Remi Collet 2013-07-26 10:54:44 EDT
Stupid of me... php-pecl-event requires php 5.4 so is not suitable for EPEL.

Forgive this one.

Note You need to log in before you can comment on or make changes to this bug.