This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 988900 - Dist-geo-rep : files are not synced if own/group is other than root + after that even files are created as root all of them are not synced to slave
Dist-geo-rep : files are not synced if own/group is other than root + after t...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
high Severity urgent
: ---
: ---
Assigned To: Venky Shankar
amainkar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-26 12:18 EDT by Rachana Patel
Modified: 2015-04-20 07:58 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.24rhs-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:38:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file of the geo-rep (3.92 MB, text/x-log)
2013-08-26 09:28 EDT, M S Vishwanath Bhat
no flags Details

  None (edit)
Description Rachana Patel 2013-07-26 12:18:30 EDT
Description of problem:
 Dist-geo-rep : files are not synced if own/group is other than root

Version-Release number of selected component (if applicable):
3.4.0.12rhs.beta6-1.el6rhs.x86_64

How reproducible:
always

Steps to Reproduce:
1. create a geo rep session between master and slave cluster
2. files are moved on master volume -  mount (owner/group is not root; )
those files are not synced on slave

Actual results:
files are not synced if own/group is other than root

Expected results:
It should sync all files

Additional info:
Comment 2 Rachana Patel 2013-07-28 13:21:12 EDT
files which are owned by User(s) other than root are not synced.
But after that created files as root users ans all of them are not synced to Slave.
Comment 3 M S Vishwanath Bhat 2013-08-26 08:11:59 EDT
This issue still exists.

I created a normal user and wrote few files to the master as that user. Those files are not synced to slave. And as this gets into a infinite loop of retrying to sync these files, any files created/edited after this will not get synced.

I see these errors in log files in  a infinite loop.


[2013-08-26 17:38:17.785479] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/213ab8e0-8a0b-4377-a4fb-93be68eda086 [errcode: 23]
[2013-08-26 17:38:17.786556] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/9d14197b-3d97-4885-a66b-ab6cdd207056 [errcode: 23]
[2013-08-26 17:38:17.788774] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/960b475e-d188-4a2d-9df2-f375e354668c [errcode: 23]
[2013-08-26 17:38:17.791429] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/511563f8-78b2-4ec3-82a1-6a5c7aff8b69 [errcode: 23]
[2013-08-26 17:38:17.792213] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/aff57895-bfa0-45bd-8a8c-c35babf9d400 [errcode: 23]
[2013-08-26 17:38:17.794595] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/2ca89fb8-1f2b-45ea-b741-906c4336b5bb [errcode: 23]
[2013-08-26 17:38:17.796859] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/85030d8a-3bb3-469a-991d-3f5064ef18e7 [errcode: 23]
[2013-08-26 17:38:17.799017] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/08389793-267c-4479-962a-f1bbc95c52e3 [errcode: 23]
[2013-08-26 17:38:17.802027] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/7d92fecc-7dce-4e25-b987-57ea5e1ec47f [errcode: 23]
[2013-08-26 17:38:17.802843] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/af6378ed-f1eb-4051-ba24-e34e13e0c6de [errcode: 23]
[2013-08-26 17:38:17.805367] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/48b0e2d9-b4be-4d4c-a6f2-bd14860340f3 [errcode: 23]
[2013-08-26 17:38:17.808465] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/4e4885a1-d218-4870-8f29-05919b544b55 [errcode: 23]
[2013-08-26 17:38:17.809340] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/bf72c625-dc31-4bbc-965d-b8516ccf1653 [errcode: 23]
[2013-08-26 17:38:17.811585] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/2440300f-f353-40e5-9ed3-d568baf8250a [errcode: 23]
[2013-08-26 17:38:17.812479] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/a0ba5fee-0d7a-43c4-94bb-a760e9883b83 [errcode: 23]
[2013-08-26 17:38:17.815022] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/1255ba82-44b4-446e-a9b9-2732691ef3e2 [errcode: 23]
[2013-08-26 17:38:17.817254] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/78f5a8c3-4122-44b2-9d64-96eec148063d [errcode: 23]
[2013-08-26 17:38:17.818213] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/9f1eb236-e788-4820-ba54-5c10fe52f88a [errcode: 23]
[2013-08-26 17:38:17.820688] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/6a0ba4d5-512e-4177-8e79-72373bd8a32c [errcode: 23]
[2013-08-26 17:38:17.821574] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/b31042b1-0e30-449b-95c8-733e616fde96 [errcode: 23]
[2013-08-26 17:38:17.823791] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/6b175c12-64e6-4383-8917-17f6b823ffc8 [errcode: 23]
[2013-08-26 17:38:17.825982] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/6ff6a8d7-cf55-49b6-82d4-f65179b2c0d7 [errcode: 23]
[2013-08-26 17:38:17.828103] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/0e0eefdc-294f-441b-a061-8d53ea12b969 [errcode: 23]
[2013-08-26 17:38:17.831804] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/3c380a70-b6f7-453a-9bbb-c4dbc4e1838c [errcode: 23]
[2013-08-26 17:38:17.832770] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/ff946b16-dab9-475f-ac5a-2dd61ff5fd35 [errcode: 23]
[2013-08-26 17:38:17.835000] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/901b2699-1b11-4760-9e87-58bc41fa8c55 [errcode: 23]
[2013-08-26 17:38:17.837250] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/33eba10e-fbdd-4ff7-8950-cf0f29c1981b [errcode: 23]
[2013-08-26 17:38:17.839296] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/3ecc7bb7-8bd0-4efa-9c84-2255d773ae0b [errcode: 23]
[2013-08-26 17:38:17.840276] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/dee13937-fc19-4974-869b-12949fcfdf25 [errcode: 23]
[2013-08-26 17:38:17.842325] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/6dacfe27-721c-4947-a763-2a7fb70d8627 [errcode: 23]
[2013-08-26 17:38:17.843216] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/da80109a-fd24-4663-8a1d-6433a4fe7caf [errcode: 23]
[2013-08-26 17:38:17.844950] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/2d74a1bd-9160-4707-b56b-2250d91674f0 [errcode: 23]
[2013-08-26 17:38:17.846782] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/27db5c5e-e786-4c4c-bf40-ce7d1414a451 [errcode: 23]
[2013-08-26 17:38:17.848681] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/947d952e-a340-4483-bcd2-ae854ce875d1 [errcode: 23]
[2013-08-26 17:38:17.849500] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/a1730e0d-1ea4-4c56-8b98-d2ddca0b6881 [errcode: 23]
[2013-08-26 17:38:17.852695] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/3929e672-30f6-4546-b495-51e229df35e3 [errcode: 23]
[2013-08-26 17:38:17.853660] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/fc8f4d83-62da-458f-8a6e-8036bd599e20 [errcode: 23]
[2013-08-26 17:38:17.856631] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/36dfd121-60e0-42bb-969b-10df2ef20d2b [errcode: 23]
[2013-08-26 17:38:17.858846] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/e47b782b-e51a-4894-8e5c-0a526dc2e3a9 [errcode: 23]
[2013-08-26 17:38:17.861637] W [master(/bricks/brick1):618:regjob] <top>: Rsync: .gfid/02fa34d6-90c0-48cc-8ad8-64e1208e1f61 [errcode: 23]
[2013-08-26 17:38:17.862514] W [master(/bricks/brick1):748:process] _GMaster: incomplete sync, retrying changelog: /var/run/gluster/master/ssh%3A%2F%2Froot%4010.70.43.25%3Agluster%3A%2F%2F127.0.0.1%3Aslave/bd42ad17ef8864d51407b1c6478f5dc6/.processing/CHANGELOG.1377518004
Comment 4 M S Vishwanath Bhat 2013-08-26 09:28:05 EDT
Created attachment 790526 [details]
log file of the geo-rep

Attaching the geo-rep log file from master.
Comment 5 Amar Tumballi 2013-08-27 02:20:58 EDT
https://code.engineering.redhat.com/gerrit/#/c/12000
Comment 6 Amar Tumballi 2013-08-27 06:15:27 EDT
https://code.engineering.redhat.com/gerrit/#/c/12023
Comment 7 Vijaykumar Koppad 2013-08-29 02:35:27 EDT
verified on glusterfs-3.4.0.24rhs-1
Comment 8 Scott Haines 2013-09-23 18:38:46 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 9 Scott Haines 2013-09-23 18:41:29 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.