Bug 988914 - Dist-geo-rep : It should abort establishment of relationship unless force flag specified If files exist in destination
Dist-geo-rep : It should abort establishment of relationship unless force fla...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Avra Sengupta
amainkar
: TestBlocker
Depends On:
Blocks: 990997
  Show dependency treegraph
 
Reported: 2013-07-26 13:09 EDT by Rachana Patel
Modified: 2015-04-20 07:57 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.15rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 990997 (view as bug list)
Environment:
Last Closed: 2013-09-23 18:29:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rachana Patel 2013-07-26 13:09:24 EDT
Description of problem:
Dist-geo-rep : It should abort establishment of relationship unless force flag specified If files exist in destination

Version-Release number of selected component (if applicable):
3.4.0.12rhs.beta6-1.el6rhs.x86_64

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
User is not getting any error or warning message If files exist in destination and It creates session and also sync files without force flag

Expected results:
It should abort establishment of relationship unless force flag specified If files exist in destination 

Additional info:
Comment 3 Amar Tumballi 2013-08-01 14:51:48 EDT
https://code.engineering.redhat.com/gerrit/#/c/11017
Comment 4 Rachana Patel 2013-08-22 06:21:00 EDT
verified with 3.4.0.20rhs-2.el6rhs.x86_64
working as expected hence changing status to verified
Comment 5 Scott Haines 2013-09-23 18:29:51 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.