Bug 988969 - [Perf] HEAD requests still execute a full container object count
[Perf] HEAD requests still execute a full container object count
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-swift (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Luis Pabón
pushpesh sharma
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-26 15:43 EDT by Luis Pabón
Modified: 2016-11-08 17:25 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:32:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luis Pabón 2013-07-26 15:43:35 EDT
Description of problem:
Containers with millions of files will make HEAD requests take a large amount of time (minutes) to determine the information about all the objects it contains.

Second, the name "object_only" in fs.conf is misleading and needs to be changed.

Version-Release number of selected component (if applicable):


How reproducible:
TBD

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Luis Pabón 2013-07-26 17:07:39 EDT
Fix in process:  http://review.gluster.org/5403
Comment 3 Luis Pabón 2013-07-29 14:00:20 EDT
Fix is now available in downstream gluster-swift-plugin-1.8.0-3.el6
Comment 4 pushpesh sharma 2013-08-05 07:45:48 EDT
Catalyst workload execution on a QE setup completed without errors.Marking as verified.

[root@dhcp207-149 ~]# rpm -qa|grep swift
gluster-swift-container-1.8.0-6.11.el6rhs.noarch
python-swiftclient-1.4.0-1.el6.noarch
gluster-swift-1.8.0-6.11.el6rhs.noarch
gluster-swift-proxy-1.8.0-6.11.el6rhs.noarch
gluster-swift-account-1.8.0-6.11.el6rhs.noarch
gluster-swift-object-1.8.0-6.11.el6rhs.noarch
gluster-swift-plugin-1.8.0-4.el6rhs.noarch
Comment 6 Scott Haines 2013-09-23 18:32:33 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.