Bug 989063 - SELinux is preventing /opt/google/chrome/nacl_helper_bootstrap from 'write' accesses on the file /home/Frankyboy/.xsession-errors.
SELinux is preventing /opt/google/chrome/nacl_helper_bootstrap from 'write' a...
Status: CLOSED DUPLICATE of bug 989061
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:8469790d3324b5812fb77054088...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-27 05:43 EDT by franck.bailliet
Modified: 2013-07-29 06:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-29 06:12:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description franck.bailliet 2013-07-27 05:43:51 EDT
Description of problem:
SELinux is preventing /opt/google/chrome/nacl_helper_bootstrap from 'write' accesses on the file /home/Frankyboy/.xsession-errors.

*****  Plugin leaks (86.2 confidence) suggests  ******************************

If vous souhaitez ignorer que nacl_helper_bootstrap tente d'obtenir l'accès write à .xsession-errors file car vous pensez qu'il ne devrait pas nécessiter cet accès.
Then vous devriez rapporter ceci en tant qu'anomalie.  
Vous pouvez générer un module de stratégie local pour dontaudit cet accès.
Do
# grep /opt/google/chrome/nacl_helper_bootstrap /var/log/audit/audit.log | audit2allow -D -M mypol
# semodule -i mypol.pp

*****  Plugin catchall (14.7 confidence) suggests  ***************************

If vous pensez que nacl_helper_bootstrap devrait être autorisé à accéder write sur .xsession-errors file par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep nacl_helper_boo /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:chrome_sandbox_nacl_t:s0
                              -s0:c0.c1023
Target Context                unconfined_u:object_r:samba_share_t:s0
Target Objects                /home/Frankyboy/.xsession-errors [ file ]
Source                        nacl_helper_boo
Source Path                   /opt/google/chrome/nacl_helper_bootstrap
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           google-chrome-stable-28.0.1500.71-209842.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-66.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.10.3-300.fc19.x86_64 #1 SMP Fri
                              Jul 26 00:00:58 UTC 2013 x86_64 x86_64
Alert Count                   5
First Seen                    2013-07-27 10:55:30 CEST
Last Seen                     2013-07-27 11:27:19 CEST
Local ID                      b8496174-6761-4ced-9ad4-7dda329fa918

Raw Audit Messages
type=AVC msg=audit(1374917239.511:466): avc:  denied  { write } for  pid=2570 comm="nacl_helper_boo" path="/home/Frankyboy/.xsession-errors" dev="sda5" ino=8388618 scontext=unconfined_u:unconfined_r:chrome_sandbox_nacl_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:samba_share_t:s0 tclass=file


type=AVC msg=audit(1374917239.511:466): avc:  denied  { write } for  pid=2570 comm="nacl_helper_boo" path="/home/Frankyboy/.xsession-errors" dev="sda5" ino=8388618 scontext=unconfined_u:unconfined_r:chrome_sandbox_nacl_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:samba_share_t:s0 tclass=file


type=SYSCALL msg=audit(1374917239.511:466): arch=x86_64 syscall=execve success=yes exit=0 a0=7fcc803f4428 a1=7fcc803e30c0 a2=7fffec139ca0 a3=7fcc7a82d080 items=0 ppid=1 pid=2570 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=1 tty=(none) comm=nacl_helper_boo exe=/opt/google/chrome/nacl_helper_bootstrap subj=unconfined_u:unconfined_r:chrome_sandbox_nacl_t:s0-s0:c0.c1023 key=(null)

Hash: nacl_helper_boo,chrome_sandbox_nacl_t,samba_share_t,file,write

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.10.3-300.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-07-29 06:12:47 EDT

*** This bug has been marked as a duplicate of bug 989061 ***

Note You need to log in before you can comment on or make changes to this bug.