Bug 989066 - SELinux is preventing /usr/bin/kdm from 'unlink' accesses on the file /home/Frankyboy/.xsession-errors-:0.
SELinux is preventing /usr/bin/kdm from 'unlink' accesses on the file /home/F...
Status: CLOSED DUPLICATE of bug 989064
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:42bb7446b3b2921cdcdea61e846...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-27 05:45 EDT by franck.bailliet
Modified: 2013-07-29 06:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-29 06:13:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description franck.bailliet 2013-07-27 05:45:09 EDT
Description of problem:
SELinux is preventing /usr/bin/kdm from 'unlink' accesses on the file /home/Frankyboy/.xsession-errors-:0.

*****  Plugin catchall (100. confidence) suggests  ***************************

If vous pensez que kdm devrait être autorisé à accéder unlink sur .xsession-errors-:0 file par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep kdm /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:samba_share_t:s0
Target Objects                /home/Frankyboy/.xsession-errors-:0 [ file ]
Source                        kdm
Source Path                   /usr/bin/kdm
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           kdm-4.10.5-3.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-66.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.10.3-300.fc19.x86_64 #1 SMP Fri
                              Jul 26 00:00:58 UTC 2013 x86_64 x86_64
Alert Count                   3
First Seen                    2013-07-27 10:53:51 CEST
Last Seen                     2013-07-27 11:21:31 CEST
Local ID                      f69f0131-c34f-446f-8c53-3aa641a4654a

Raw Audit Messages
type=AVC msg=audit(1374916891.857:496): avc:  denied  { unlink } for  pid=2945 comm="kdm" name=".xsession-errors-:0" dev="sda5" ino=8388616 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:samba_share_t:s0 tclass=file


type=SYSCALL msg=audit(1374916891.857:496): arch=x86_64 syscall=unlink success=no exit=EACCES a0=19fe1b0 a1=19ba422 a2=0 a3=7fff1e8e6e60 items=0 ppid=2901 pid=2945 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=2 tty=(none) comm=kdm exe=/usr/bin/kdm subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)

Hash: kdm,xdm_t,samba_share_t,file,unlink

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.10.3-300.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-07-29 06:13:18 EDT

*** This bug has been marked as a duplicate of bug 989064 ***

Note You need to log in before you can comment on or make changes to this bug.