Bug 989067 - SELinux is preventing /opt/google/chrome/chrome from 'read' accesses on the file /home/Frankyboy/.config/google-chrome/Default/Pepper Data/Shockwave Flash/WritableRoot/#SharedObjects/G7AJ2FQU/macromedia.com/support/flashplayer/sys/settings.sol.
SELinux is preventing /opt/google/chrome/chrome from 'read' accesses on the f...
Status: CLOSED DUPLICATE of bug 989061
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:abb088c6d69d282b0c7fd13d198...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-27 05:45 EDT by franck.bailliet
Modified: 2013-07-29 06:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-29 06:13:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description franck.bailliet 2013-07-27 05:45:36 EDT
Description of problem:
SELinux is preventing /opt/google/chrome/chrome from 'read' accesses on the file /home/Frankyboy/.config/google-chrome/Default/Pepper Data/Shockwave Flash/WritableRoot/#SharedObjects/G7AJ2FQU/macromedia.com/support/flashplayer/sys/settings.sol.

*****  Plugin chrome (98.5 confidence) suggests  *****************************

If vous voulez utiliser le paquet plugin
Then vous devrez désactiver les contrôles SELinux sur les greffons Chrome.
Do
# setsebool unconfined_chrome_sandbox_transition 0

*****  Plugin catchall (2.46 confidence) suggests  ***************************

If vous pensez que chrome devrait être autorisé à accéder read sur settings.sol file par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep Chrome_ChildIOT /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c
                              0.c1023
Target Context                unconfined_u:object_r:samba_share_t:s0
Target Objects                /home/Frankyboy/.config/google-
                              chrome/Default/Pepper Data/Shockwave Flash/Writabl
                              eRoot/#SharedObjects/G7AJ2FQU/macromedia.com/suppo
                              rt/flashplayer/sys/settings.sol [ file ]
Source                        Chrome_ChildIOT
Source Path                   /opt/google/chrome/chrome
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           google-chrome-stable-28.0.1500.71-209842.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-65.fc19.noarch selinux-
                              policy-3.12.1-66.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.9-302.fc19.x86_64 #1 SMP Sat
                              Jul 6 13:41:07 UTC 2013 x86_64 x86_64
Alert Count                   2
First Seen                    2013-07-27 11:11:14 CEST
Last Seen                     2013-07-27 11:11:15 CEST
Local ID                      98a535fb-db46-4354-812c-3f87042af92a

Raw Audit Messages
type=AVC msg=audit(1374916275.476:502): avc:  denied  { read } for  pid=3480 comm="Chrome_ChildIOT" path=2F686F6D652F4672616E6B79626F792F2E636F6E6669672F676F6F676C652D6368726F6D652F44656661756C742F50657070657220446174612F53686F636B7761766520466C6173682F5772697461626C65526F6F742F235368617265644F626A656374732F4737414A324651552F6D6163726F6D656469612E636F6D2F737570706F72742F666C617368706C617965722F7379732F73657474696E67732E736F6C dev="sda5" ino=1837354 scontext=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:samba_share_t:s0 tclass=file


type=SYSCALL msg=audit(1374916275.476:502): arch=x86_64 syscall=recvmsg success=yes exit=EPERM a0=12 a1=7fcccb475360 a2=40 a3=1 items=0 ppid=6 pid=3480 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=1 tty=(none) comm=Chrome_ChildIOT exe=/opt/google/chrome/chrome subj=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 key=(null)

Hash: Chrome_ChildIOT,chrome_sandbox_t,samba_share_t,file,read

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.10.3-300.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-07-29 06:13:38 EDT

*** This bug has been marked as a duplicate of bug 989061 ***

Note You need to log in before you can comment on or make changes to this bug.