Bug 989088 - installonly_limit defaults to 3, not 0
installonly_limit defaults to 3, not 0
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-27 09:10 EDT by Steve Tyler
Modified: 2013-08-04 16:57 EDT (History)
7 users (show)

See Also:
Fixed In Version: yum-3.4.3-104.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-04 16:57:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/yum.conf (814 bytes, text/plain)
2013-07-27 09:10 EDT, Steve Tyler
no flags Details
yum update session showing kernel being removed (37.01 KB, text/plain)
2013-07-27 09:21 EDT, Steve Tyler
no flags Details

  None (edit)
Description Steve Tyler 2013-07-27 09:10:26 EDT
Created attachment 779083 [details]
/etc/yum.conf

Description of problem:
The yum.conf man page says installonly_limit defaults to 0, but a kernel update shows that it defaults to 3.

$ grep installonly_limit /etc/yum.conf 
#installonly_limit=3

$ rpm -q kernel
kernel-3.9.9-301.fc19.x86_64
kernel-3.9.9-302.fc19.x86_64
kernel-3.10.3-300.fc19.x86_64

Version-Release number of selected component (if applicable):
yum-3.4.3-102.fc19.noarch

How reproducible:
Presumably always.

Steps to Reproduce:
1. Comment out installonly_limit in yum.conf:
$ grep installonly_limit /etc/yum.conf 
#installonly_limit=3

1. Install 3 kernels.
2. Update with a fourth kernel.

Actual results:
Oldest kernel is removed.

Expected results:
Oldest kernel is not removed,
Or
The yum.conf man pages says installonly_limit defaults to 3.

Additional info:
$ sudo yum plugins
Loaded plugins: changelog, langpacks
No such command: plugins. Please use /bin/yum --help
Comment 1 Steve Tyler 2013-07-27 09:13:12 EDT
Snippet from yum.conf man page:

$ man yum.conf
...
installonly_limit Number of packages listed in installonlypkgs to keep installed at the same time. Setting to 0 disables this feature. Default is '0'.
...
Comment 2 Steve Tyler 2013-07-27 09:21:28 EDT
Created attachment 779086 [details]
yum update session showing kernel being removed

...
Removing:
 kernel                          x86_64   3.9.8-300.fc19       @updates   124 M
 kernel-modules-extra            x86_64   3.9.8-300.fc19       @updates   8.3 M
...
Comment 3 Steve Tyler 2013-07-27 09:27:43 EDT
$ rpm -V yum
S.5....T.  c /etc/yum.conf
Comment 4 Steve Tyler 2013-07-27 09:46:08 EDT
$ sudo grep kernel-3 /var/log/yum.log 
Jun 29 23:08:52 Installed: kernel-3.9.6-301.fc19.x86_64
Jul 01 06:39:14 Installed: kernel-3.9.8-300.fc19.x86_64
Jul 01 06:49:44 Erased: kernel-3.9.8-300.fc19.x86_64
Jul 01 06:52:01 Installed: kernel-3.9.8-300.fc19.x86_64
Jul 06 10:00:29 Installed: kernel-3.9.9-301.fc19.x86_64
Jul 14 21:53:11 Installed: kernel-3.9.9-302.fc19.x86_64
Jul 27 05:33:01 Installed: kernel-3.10.3-300.fc19.x86_64
Comment 5 Zdeněk Pavlas 2013-07-29 04:02:41 EDT
Seems to be a packaging error.. yum-distro-configs.patch (that sets the default to 3) is used, but installonlyn-enable.patch that updates documentation accordingly is not.  Will fix in next release.
Comment 6 Steve Tyler 2013-07-29 11:42:19 EDT
Thanks:
yum-distro-configs: update installonly_limit default in yum.conf.5
http://pkgs.fedoraproject.org/cgit/yum.git/commit/?h=f19&id=a08b310baae4e7b06a224a4f8843b804b8d19641
Comment 7 Steve Tyler 2013-08-04 16:57:08 EDT
Verified fixed with yum-3.4.3-104.fc19.noarch.
Setting to CLOSED/CURRENTRELEASE.

$ man yum.conf | grep installonly_limit
              installonly_limit Number of packages listed in installonlypkgs to keep installed at the same time. Setting to 0 disables this feature. Default is '3'. Note that this functionality used to  be
$ rpm -q yum
yum-3.4.3-104.fc19.noarch

Note You need to log in before you can comment on or make changes to this bug.