Bug 989093 - Garbage displayed after resume from suspend to RAM [Linux 3.10]
Garbage displayed after resume from suspend to RAM [Linux 3.10]
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 989501 989720 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-27 09:37 EDT by Brandon
Modified: 2013-08-01 23:32 EDT (History)
7 users (show)

See Also:
Fixed In Version: kernel-3.10.4-300.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 23:32:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 60530 None None None Never

  None (edit)
Description Brandon 2013-07-27 09:37:22 EDT
I just got updated to kernel 3.10 from fedora updates. Running fedora 19 64-bit on a system76 lemur ultra with intel HD4000 graphics. Now almost every time I resume from suspend I get a totally unusable display filled with artifacts and garbage and have to switch to a tty and reboot.

This is a known upstream bug, its a regression from 3.9 > 3.10: https://bugzilla.kernel.org/show_bug.cgi?id=60530

There is a patch to fix it on the bug report comments. Apparently the fix wasn't included in 3.10.3 which is the 3.10 kernel fedora updated me to. This update really should not have been released with such a severe known bug.
Comment 1 Josh Boyer 2013-07-29 08:34:12 EDT
*** Bug 989501 has been marked as a duplicate of this bug. ***
Comment 2 Josh Boyer 2013-07-29 08:42:12 EDT
I've added the patch from the kernel.org bug.  A build should be coming today.
Comment 3 Josh Boyer 2013-07-29 15:09:10 EDT
*** Bug 989720 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2013-07-30 10:08:13 EDT
kernel-3.10.4-300.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kernel-3.10.4-300.fc19
Comment 5 Fedora Update System 2013-08-01 23:32:18 EDT
kernel-3.10.4-300.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.