Bug 989197 - unrecognized touchpad
unrecognized touchpad
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-28 04:25 EDT by Frédéric Bron
Modified: 2013-09-20 09:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-20 09:10:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/{messages,Xorg.0.log} (208.34 KB, application/x-bzip)
2013-07-28 04:25 EDT, Frédéric Bron
no flags Details

  None (edit)
Description Frédéric Bron 2013-07-28 04:25:53 EDT
Created attachment 779290 [details]
/var/log/{messages,Xorg.0.log}

Description of problem:

After an update, I lost the touchpad.
grep -i touchpad /var/log/messages gives:
Jul 28 10:55:53 casalibus kernel: [    5.405063] psmouse serio2: synaptics: Touchpad model: 1, fw: 7.2, id: 0x1c0b1, caps: 0xd04733/0xa40000/0xa0000, board id: 3655, fw id: 582762
Jul 28 10:55:53 casalibus kernel: [    5.447080] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio2/input/input6

But lsusb reports nothing.

In /var/log/Xorg.0.log (the last two lines look strange to me):
[    10.074] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event6)
[    10.074] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[    10.074] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[    10.074] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "Default clickpad buttons"
[    10.074] (II) LoadModule: "synaptics"
[    10.074] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
[    10.075] (II) Module synaptics: vendor="X.Org Foundation"
[    10.075] > compiled for 1.14.2, module version = 1.7.1
[    10.075] > Module class: X.Org XInput Driver
[    10.075] > ABI class: X.Org XInput driver, version 19.2
[    10.075] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[    10.075] > Option "_source" "server/udev"
[    10.075] > Option "name" "SynPS/2 Synaptics TouchPad"
[    10.075] > Option "path" "/dev/input/event6"
[    10.075] > Option "device" "/dev/input/event6"
[    10.075] > Option "config_info" "udev:/sys/devices/platform/i8042/serio2/input/input6/event6"
[    10.075] > Option "driver" "synaptics"
[    10.075] > Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
[    10.075] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    10.075] (**) Option "Device" "/dev/input/event6"
[    10.101] (**) Option "Device" "/dev/input/event6"
[    10.101] port opened successfully
[    10.101] (II) synaptics: SynPS/2 Synaptics TouchPad: ignoring touch events for semi-multitouch device
[    10.101] (--) synaptics: SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5692 (res 66)
[    10.101] (--) synaptics: SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4680 (res 102)
[    10.101] (--) synaptics: SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[    10.101] (--) synaptics: SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[    10.101] (--) synaptics: SynPS/2 Synaptics TouchPad: buttons: left right double triple
[    10.101] (--) synaptics: SynPS/2 Synaptics TouchPad: Vendor 0x2 Product 0x7
[    10.101] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    10.101] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    10.111] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio2/input/input6/event6"
[    10.111] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD, id 12)
[    10.111] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[    10.111] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MaxSpeed is now 1.75
[    10.111] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) AccelFactor is now 0.037
[    10.111] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[    10.111] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[    10.111] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[    10.111] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[    10.111] (**) Option "Device" "/dev/input/event6"
[    10.111] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    10.112] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[    10.112] (II) No input driver specified, ignoring this device.
[    10.112] (II) This device may have been added with another device file.

Version-Release number of selected component (if applicable):
kernel 3.9.9 302.fc19

How reproducible:
Turn on the computer and run fedora under KDE 4.10.5.
Comment 1 Frédéric Bron 2013-08-02 13:08:03 EDT
I would like to add that the touchpad works in the display manager (kdm). The touchpad stops working when KDE itself starts.
Comment 2 Frédéric Bron 2013-08-09 02:24:28 EDT
problem is fixed but still very strange:
in the KDE system configuration/input devices, the touchpad was on but I remembered I put it to off some time ago. I put it off again and on again and it was back! I do not understand how it could be on in the configuration while off in practice. Nevertheless off/on made it work again.
Comment 3 Josh Boyer 2013-09-18 16:32:35 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 4 Frédéric Bron 2013-09-20 07:21:15 EDT
please, read comment #2: this is now fixed.
Thanks
Comment 5 Josh Boyer 2013-09-20 09:10:17 EDT
Thank you.

Note You need to log in before you can comment on or make changes to this bug.