Bug 989239 - Fail to upgrade from 3.1 si29.3 to 3.2 sf19
Fail to upgrade from 3.1 si29.3 to 3.2 sf19
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.2.0
Unspecified Unspecified
urgent Severity unspecified
: ---
: 3.2.2
Assigned To: Alon Bar-Lev
Tareq Alayan
integration
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-28 11:59 EDT by Tareq Alayan
Modified: 2015-09-22 09 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-30 04:39:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upgrade log (87.72 KB, text/x-log)
2013-07-28 12:00 EDT, Tareq Alayan
no flags Details

  None (edit)
Description Tareq Alayan 2013-07-28 11:59:14 EDT
Description of problem:

Fail to upgrade from 3.1 si29.3 to 3.2 sf19

Version-Release number of selected component (if applicable):
sf19

How reproducible:
always

Steps to Reproduce:
1. install 3.1 si29.3
2. update repos
3. yum update rhevm-setup
4. rhevm-upgrade

Actual results:
Failed to upgrade from 3.1 si29.3 -> 3.2 sf19 due to: 

 **Error: Upgrade failed, rolling back**
 **Reason: One or more elements within Yum transaction failed**


attaching upgrade log.


from log:
2013-07-28 18:08:55::ERROR::common_utils::353::root:: YUM: FAIL: Error unpacking rpm package virtio-win-1.6.5-5.el6_4.noarch

Expected results:
success
Comment 1 Tareq Alayan 2013-07-28 12:00:59 EDT
Created attachment 779381 [details]
upgrade log
Comment 2 Alex Lourie 2013-07-29 12:07:57 EDT
Tareq

According to the log, there was a problem with downloading virtio-win-1.6.5-5 rpm. Can you please repeat this test? It may be that the rpm in the repo is broken.

Thanks.
Comment 4 Alon Bar-Lev 2013-07-29 16:25:16 EDT
I see no problem in sf19 repo, it is also unlikely be our issue.

bug#693953?

What happens if you try to update manually?

# yum --disableplugin=versionlock update rhevm

I will check this at your host.
Comment 5 Alon Bar-Lev 2013-07-29 16:27:52 EDT
Same issue with regular yum:

(10/15): rhevm-notification-service-3.2.2-0.40.el6ev.noarch.rpm                |  51 kB     00:00     
(11/15): rhevm-restapi-3.2.2-0.40.el6ev.noarch.rpm                             | 1.1 MB     00:00     
(12/15): rhevm-tools-common-3.2.2-0.40.el6ev.noarch.rpm                        |  11 kB     00:00     
(13/15): rhevm-userportal-3.2.2-0.40.el6ev.noarch.rpm                          |  72 MB     00:01     
(14/15): rhevm-webadmin-portal-3.2.2-0.40.el6ev.noarch.rpm                     |  93 MB     00:01     
(15/15): virtio-win-1.6.5-5.el6_4.noarch.rpm                                   |  45 MB     00:00     
------------------------------------------------------------------------------------------------------
Total                                                                  54 MB/s | 221 MB     00:04     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : otopi-1.0.0-2.el6ev.noarch                                                        1/25 
  Installing : ovirt-host-deploy-1.0.0-2.el6ev.noarch                                            2/25 
  Installing : otopi-java-1.0.0-2.el6ev.noarch                                                   3/25 
  Installing : ovirt-host-deploy-java-1.0.0-2.el6ev.noarch                                       4/25 
  Installing : virtio-win-1.6.5-5.el6_4.noarch                                                   5/25 
Error unpacking rpm package virtio-win-1.6.5-5.el6_4.noarch
error: unpacking of archive failed on file /usr/share/virtio-win/virtio-win-1.6.5.iso;51f6d007: cpio: read
  Updating   : rhevm-userportal-3.2.2-0.40.el6ev.noarch                                          6/25 
  Updating   : rhevm-dbscripts-3.2.2-0.40.el6ev.noarch                                           7/25
Comment 6 Alon Bar-Lev 2013-07-29 16:29:16 EDT
Please remember that yum command:

# yum --disableplugin=versionlock update rhevm

Every time you have an issue with our upgrade that is yum related, please run this manually for elimination process.
Comment 7 Alon Bar-Lev 2013-07-29 16:30:24 EDT
# yum install virtio-win
Loaded plugins: product-id, subscription-manager, versionlock
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package virtio-win.noarch 0:1.6.5-5.el6_4 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

======================================================================================================
 Package                 Arch                Version                    Repository               Size
======================================================================================================
Installing:
 virtio-win              noarch              1.6.5-5.el6_4              qa-build-1               45 M

Transaction Summary
======================================================================================================
Install       1 Package(s)

Total download size: 45 M
Installed size: 95 M
Is this ok [y/N]: y
Downloading Packages:
virtio-win-1.6.5-5.el6_4.noarch.rpm                                            |  45 MB     00:00     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : virtio-win-1.6.5-5.el6_4.noarch                                                    1/1 
Error unpacking rpm package virtio-win-1.6.5-5.el6_4.noarch
error: unpacking of archive failed on file /usr/share/virtio-win/virtio-win-1.6.5.iso;51f6d0bd: cpio: read
  Verifying  : virtio-win-1.6.5-5.el6_4.noarch                                                    1/1 

Failed:
  virtio-win.noarch 0:1.6.5-5.el6_4                                                                   

Complete!
Comment 8 Alon Bar-Lev 2013-07-29 16:33:37 EDT
# yum clean all

does not help.
Comment 9 Alon Bar-Lev 2013-07-29 16:41:04 EDT
Changing the repo name does not help.
Comment 10 Alon Bar-Lev 2013-07-29 16:45:40 EDT
ulimit is not likely the problem.

working at other computer.

I am out of ideas, but this is generic yum issue, unrelated to ovirt.
Comment 11 Alex Lourie 2013-07-30 04:38:26 EDT
You have the following in rhevm.repo:

[qa-build-1]
name=QA build
baseurl=http://bob.eng.lab.tlv.redhat.com/builds/si29.3
enabled=1
gpgcheck=0

[qa-build-22]
name=qa-build-22
baseurl=http://bob.eng.lab.tlv.redhat.com/builds/sf19
enabled=1
gpgcheck=0


Both repos have the same numbered virtio-win-1.6.5-5.el6_4.noarch package.

Yum selects qa-build-1 (as probably the first one suppliying that package) so it installs it from si29.3, where the package is really broken: on my host:

Running Transaction

...
Error unpacking rpm package virtio-win-1.6.5-5.el6_4.noarch
error: unpacking of archive failed on file /usr/share/virtio-win/virtio-win-1.6.5.iso;51f77a7b: cpio: read
....
Failed:
  virtio-win.noarch 0:1.6.4-1.el6_4                  virtio-win.noarch 0:1.6.5-5.el6_4                 
....
Complete!
[root@vm-37-164 ~]# 

While in sf19 everything is ok:

....
Total download size: 45 M
Installed size: 95 M
Is this ok [y/N]: y
Downloading Packages:
virtio-win-1.6.5-5.el6_4.noarch.rpm                                              |  45 MB     00:00     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : virtio-win-1.6.5-5.el6_4.noarch                                                      1/1 
  Verifying  : virtio-win-1.6.5-5.el6_4.noarch                                                      1/1 

Installed:
  virtio-win.noarch 0:1.6.5-5.el6_4                  


Closing as not a bug.
Comment 12 Tareq Alayan 2013-07-30 06:24:12 EDT
closing

Note You need to log in before you can comment on or make changes to this bug.