Bug 989245 - Dist-geo-rep : 'gluster volume geo status' is showing status as defunct but with config option it says session does not exists
Dist-geo-rep : 'gluster volume geo status' is showing status as defunct but w...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: Avra Sengupta
amainkar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-28 13:38 EDT by Rachana Patel
Modified: 2015-04-20 07:56 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.15rhs-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:38:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rachana Patel 2013-07-28 13:38:28 EDT
Description of problem:
Dist-geo-rep : 'gluster volume geo status' is showing status as defunct but with config option it says session does not exists 

Version-Release number of selected component (if applicable):
3.4.0.12rhs.beta6-1.el6rhs.x86_64

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
[root@DVM1 ~]# gluster volume geo master2 rhsauto031.lab.eng.blr.redhat.com::slave2 status

NODE                           MASTER     SLAVE                                        HEALTH     UPTIME       
---------------------------------------------------------------------------------------------------------------
DVM1.lab.eng.blr.redhat.com    master2    rhsauto031.lab.eng.blr.redhat.com::slave2    defunct    N/A          
DVM4.lab.eng.blr.redhat.com    master2    rhsauto031.lab.eng.blr.redhat.com::slave2    defunct    N/A          
DVM2.lab.eng.blr.redhat.com    master2    rhsauto031.lab.eng.blr.redhat.com::slave2    defunct    N/A          
DVM6.lab.eng.blr.redhat.com    master2    rhsauto031.lab.eng.blr.redhat.com::slave2    defunct    N/A          
DVM5.lab.eng.blr.redhat.com    master2    rhsauto031.lab.eng.blr.redhat.com::slave2    defunct    N/A          
DVM3.lab.eng.blr.redhat.com    master2    rhsauto031.lab.eng.blr.redhat.com::slave2    defunct    N/A          
[root@DVM1 ~]# 
[root@DVM1 ~]# gluster volume geo master2 rhsauto031.lab.eng.blr.redhat.com::slave2  config
Geo-replication session between master2 and rhsauto031.lab.eng.blr.redhat.com::slave2 does not exist.
geo-replication command failed


Expected results:


Additional info:
Comment 2 Avra Sengupta 2013-08-02 02:57:44 EDT
should be resolved with https://code.engineering.redhat.com/gerrit/#/c/10827/
Please reopen if it resurfaces with this patch as well.
Comment 3 Rachana Patel 2013-08-13 01:27:10 EDT
verified with 3.4.0.18rhs-1.el6rhs.x86_64,
Comment 4 Scott Haines 2013-09-23 18:38:48 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 5 Scott Haines 2013-09-23 18:41:29 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.