Bug 989247 - Dist-geo-rep : in case of slave hostname unreachable, 'gluster volume geo <master_vol> <slave_ip>::<slave_vol> start/stop/config' says 'Staging failed on localhost'
Dist-geo-rep : in case of slave hostname unreachable, 'gluster volume geo <m...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: Avra Sengupta
amainkar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-28 13:53 EDT by Rachana Patel
Modified: 2015-04-20 07:58 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.19rhs-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:38:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rachana Patel 2013-07-28 13:53:19 EDT
Description of problem:
Dist-geo-rep : in case of hostname unreachable,  'gluster volume geo <mater_vol> <slave_ip>::<slvae_vol> start/stop/config' says 'Staging failed on localhost'

Version-Release number of selected component (if applicable):
3.4.0.12rhs.beta6-1.el6rhs.x86_64

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
[root@DVM1 ~]# gluster volume geo  test5  abc.lab.eng.blr.redhat.com::slavecon stop
Staging failed on localhost. Please check the log file for more details.
geo-replication command failed
[root@DVM1 ~]# gluster volume geo  test5  abc.lab.eng.blr.redhat.com::slavecon start
Staging failed on localhost. Please check the log file for more details.
geo-replication command failed


[root@DVM1 ~]# gluster volume geo  test5  abc.lab.eng.blr.redhat.com::slavecon config
Staging failed on localhost. Please check the log file for more details.
geo-replication command failed

Expected results:
slave host  abc.lab.eng.blr.redhat.com does not exist and there is no geo rep session with that host.

start/stop/config should say there is no geo rep session between master and slave rather than staging failed error

Additional info:
Comment 2 Avra Sengupta 2013-08-07 10:08:04 EDT
Fix is in the patch https://code.engineering.redhat.com/gerrit/11204
Comment 3 Avra Sengupta 2013-08-07 10:13:23 EDT
In case of unreachable and invalid Ip's like a.b.c.d, the cli will display a.b.c.d. is not reachable.
Comment 4 Sayan Saha 2013-08-12 20:04:49 EDT
Agree with comment #3 and the error message. This does not need to be a blocker but should be fixed in RHSS 2.1.
Comment 5 Amar Tumballi 2013-08-13 04:43:46 EDT
Taken in. Url: same as comment #2
Comment 6 Rachana Patel 2013-08-22 06:21:27 EDT
verified with 3.4.0.20rhs-2.el6rhs.x86_64
working as mentioned in comment #3, hence changing status to verified
Comment 7 Scott Haines 2013-09-23 18:38:48 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 8 Scott Haines 2013-09-23 18:41:30 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.