Bug 989248 - Dist-geo-rep : 'gluster volume geo <master_vol> <slave_ip>::<slave_vol> stop' gives wrong error message if session does not exist
Dist-geo-rep : 'gluster volume geo <master_vol> <slave_ip>::<slave_vol> stop'...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Avra Sengupta
amainkar
:
Depends On:
Blocks: 989541
  Show dependency treegraph
 
Reported: 2013-07-28 13:58 EDT by Rachana Patel
Modified: 2015-04-20 07:58 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.15rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 989541 (view as bug list)
Environment:
Last Closed: 2013-09-23 18:38:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rachana Patel 2013-07-28 13:58:50 EDT
Description of problem:
Dist-geo-rep : 'gluster volume geo <master_vol> <slave_ip>::<slave_vol> stop'  gives wrong error message if session does not exist.
(slave host is reachable)

Version-Release number of selected component (if applicable):
3.4.0.12rhs.beta6-1.el6rhs.x86_64

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
[root@DVM1 ~]# gluster volume geo test5 rhsauto027.lab.eng.blr.redhat.com::slave2 stop
geo-replication session b/w test5 & rhsauto027.lab.eng.blr.redhat.com::slave2 is not running on this node.
geo-replication command failed

Expected results:
If session does not exist, it should not say session is not running on this node.
Should say session does not exist

Additional info:
Comment 2 Avra Sengupta 2013-07-29 09:43:55 EDT
Performing statefile check in case of geo-rep stop, so as to provide proper error message in case session is not created.

However in case of geo-rep stop force, we allow the command to succeed even in case that the session is not created, because the stop command is a failsafe command to stop running geo-rep sessions on any nodes.
Comment 4 Rachana Patel 2013-08-08 06:17:24 EDT
verified with -3.4.0.18rhs-1.el6rhs.x86_64
working as per expected result , hence moving to verified
Comment 5 Scott Haines 2013-09-23 18:38:48 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 6 Scott Haines 2013-09-23 18:41:30 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.