Bug 989293 - Unified naming rules for qemu monitor commands
Unified naming rules for qemu monitor commands
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-28 22:51 EDT by xu
Modified: 2013-08-01 19:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 19:24:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xu 2013-07-28 22:51:00 EDT
Description of problem:

Naming rules of qemu monitor commands is very confused, I thinks it very for hard for qemu tools developer to main a piece of clean code and it's not a good user experience for qemu user too;


(qemu) block
block_resize            blockdev-snapshot-sync  block_passwd            
block_set_io_throttle   block-stream            block-job-set-speed     
block-job-cancel        

Version-Release number of selected component (if applicable):

qemu-kvm-rhev-0.12.1.2-2.379.el6.x86_64

How reproducible:

100%

Steps to Reproduce:
1. boot guest with cmdline:
qemu-kvm -vnc :2 -monitor stdio

2. input "block" in qmp monitor, then type "tab" key 

Actual results:

(qemu) block
block_resize            blockdev-snapshot-sync  block_passwd            
block_set_io_throttle   block-stream            block-job-set-speed     
block-job-cancel

Expected results:

(qemu) block
block_resize            blockdev_snapshot_sync  block_passwd            
block_set_io_throttle   block_stream            block_job_set_speed     
block_job_cancel

Additional info:

we hope to rename monitor command with unified naming rule
Comment 2 Ademar Reis 2013-08-01 19:24:16 EDT
This is something that has been discussed upstream a few times, but unfortunately we can't change all commands without breaking compatibility, and the cost of introducing duplicate names to clean up everything is too high.

What we've been doing is a more careful selection of QMP command names, trying to be consistent in the new commands. Besides, the libvirt API is much more clean and that's what we push users to.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.