Bug 989331 - Admin console can not read config parameters from development configuration file in development mode
Admin console can not read config parameters from development configuration f...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Luke Meyer
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 01:23 EDT by Jianwei Hou
Modified: 2015-05-14 21:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-19 12:47:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jianwei Hou 2013-07-29 01:23:48 EDT
Description of problem:
Given I was running admin console in development mode on EC2, when I add openshift-origin-admin-console-dev.conf to /etc/openshift/plugins.d/ and restart broker/httpd services, the admin-console interface is not accessible.

Version-Release number of selected component (if applicable):
On devenv_3569

How reproducible:
Always

Steps to Reproduce:
1. Rename /etc/openshift/plugins.d/openshift-origin-admin-console.conf to /etc/openshift/plugins.d/openshift-origin-admin-console-dev.conf
2. Restart httpd, rhc-broker
3. Access admin-console interface at https://broker_host/admin-console

Actual results:
After step 3, webpage returns:
No route matches [GET] "/admin-console"

Expected results:
The admin-console should be functional under development mode, and should be able to read from development configuration file.

Additional info:
Comment 1 Luke Meyer 2013-07-29 10:31:18 EDT
Like the other broker plugins, the production configuration file must be present for the plugin to load, even if actually in development mode. Since you renamed it, the prod conf file is not there. If you just copied it, that should work.

Certainly this is confusing and I think we could probably improve the broker Gemfile so it loads if either is available. We should discuss exactly how we want to implement that (and perhaps at the same time fail more helpfully when plugins don't load for some reason), and either address this as a bug or a Trello card. 

In the meantime, lowering the severity - feel free to increase it if the development file actually does not get read when it's there (currently I think the only setting that actually does anything is MOUNT_URI).
Comment 2 Luke Meyer 2013-08-05 16:22:12 EDT
Once https://github.com/openshift/origin-server/pull/3294 drops, the presence of either the prod or -dev.conf will cause the plugin to load in Origin broker. Online broker Gemfile is testing explicitly for the prod file so -dev.conf will not cause it to load there. I don't see a need to change that.
Comment 3 Wei Sun 2013-09-04 05:33:05 EDT
Verified on fork_ami_origin_ui_58_817

Step:
1.cp openshift-origin-admin-console.conf  openshift-origin-admin-console-dev.conf
2.Change something in openshift-origin-admin-console-dev.conf
3. service httpd restart
4. service rhc-broker restart
5.Access admin-console page and check if the changes are take effect

Result:
The changes are take effect

Note You need to log in before you can comment on or make changes to this bug.