Bug 989338 - Missing git repo info on the get-started page with existing ssh key on iPad2&&safari
Missing git repo info on the get-started page with existing ssh key on iPad2&...
Status: CLOSED WORKSFORME
Product: OpenShift Online
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 02:08 EDT by Tian Feng
Modified: 2015-05-14 21:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-26 22:56:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tian Feng 2013-07-29 02:08:24 EDT
Description of problem:

On iPad2 and safari, when I add a ssh key, and then create an application and check the application overview page. It will show ”add an SSH public key to your account" link and missing git repo info.

Version-Release number of selected component (if applicable):

INT(devenv_3569) 

How reproducible:

Always

Steps to Reproduce:
1. Add an valid ssh key
2. Create an application and check the get started page
3. 

Actual results:

It returns "add an SSH public key to your account" link and missing git repo info.

Expected results:

Show the correct git repo info.

Additional info:
Comment 1 Fabiano Franz 2013-07-29 15:25:25 EDT
Unable to reproduce on Safari on a OS X Mountain Lion, could you confirm if you are referring to Safari ON the iPad2 or also Safari on Mac OS X?
Comment 2 Tian Feng 2013-07-29 20:36:59 EDT
I have tried on Safari on Mac OS X, it performs correctly. And on iPhone, it is also correct.
Comment 3 Tian Feng 2013-07-30 01:37:23 EDT
(In reply to Fabiano Franz from comment #1)
> Unable to reproduce on Safari on a OS X Mountain Lion, could you confirm if
> you are referring to Safari ON the iPad2 or also Safari on Mac OS X?

The bug only occurs on Safari && iPad2.
Comment 4 Clayton Coleman 2013-08-21 16:37:55 EDT
Must be a cookie related thing (cookie not being updated).  The cookie keeps a cached copy of the state of the response.
Comment 5 Tian Feng 2013-08-21 23:17:37 EDT
Test it later, this bug never happens. So I agree with cookie related thing.
Comment 6 Clayton Coleman 2013-09-25 16:44:49 EDT
Can I mark this as WORKSFORME?
Comment 7 Tian Feng 2013-09-26 02:03:49 EDT
Sure, you can mark it.

Note You need to log in before you can comment on or make changes to this bug.