Bug 989351 - Fail to threaddump after scale up for ruby-1.8/ruby-1.9
Fail to threaddump after scale up for ruby-1.8/ruby-1.9
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
All All
medium Severity medium
: ---
: ---
Assigned To: Hiro Asari
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 02:45 EDT by zhaozhanqi
Modified: 2015-05-14 19:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 18:57:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhaozhanqi 2013-07-29 02:45:03 EDT
Description of problem:
Given a ruby-1.8/ruby-1.9 scalable app and scale up. threaddump this app, will show errors:Unable to complete the requested operation due to: undefined method `exit_code' for #<ResultIO:0x00000005f66030>.
Reference ID: ce6e0c82f16e9c2b26d9318a2a6c1211


Version-Release number of selected component (if applicable):
INT(devenv_3569)

How reproducible:
always

Steps to Reproduce:
1. create one scalable ruby-1.9/ruby-1.8 app
2. scale up this app
   rhc cartridge scale -a $appname -c ruby-1.9 --min 2
3.threaddump this app
   rhc threaddump $appname

Actual results:

[zqzhao@dhcp-13-222 build]$ rhc threaddump zqruby18s
Unable to complete the requested operation due to: undefined method `exit_code' for #<ResultIO:0x00000005f66030>.
Reference ID: ce6e0c82f16e9c2b26d9318a2a6c1211

Expected results:

no this errors

Additional info:
Comment 1 zhaozhanqi 2013-07-29 02:46:26 EDT
Tested on devenv_3573, it will show different errors:
[root@dhcp-10-143 openshift]# rhc threaddump zqruby19s
Error occured while processing event 'thread-dump':The rhc threaddump command is not supported on scaled gear: 51f60e5234393408ad000003. ssh into the gear and issue ~/ruby/bin/control threaddump.
Comment 2 Hiro Asari 2013-07-29 10:43:07 EDT
The latter result is correct; the Ruby cart does not support threaddump command on scaled applications.

It is not clear how it sneaked into the error originally reported, but if it doesn't happen now, please close this ticket.
Comment 3 zhaozhanqi 2013-07-29 23:29:30 EDT
Tested this on INT(devenv_3578),it is ok

dhcp-10-195:.openshift root# rhc threaddump zqruby18s
Error occured while processing event 'thread-dump':The rhc threaddump command is not supported on scaled gear: 51f602e003ef6499ee000002. ssh into the gear and issue ~/ruby/bin/control threaddump

Note You need to log in before you can comment on or make changes to this bug.