Bug 989365 - Virt-who will crash after system has registered to stage candlepin on the KVM platform
Virt-who will crash after system has registered to stage candlepin on the KVM...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-who (Show other bugs)
5.10
x86_64 Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Radek Novacek
Entitlement Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 03:03 EDT by Liushihui
Modified: 2016-11-30 19:31 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-05 07:19:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Liushihui 2013-07-29 03:03:51 EDT
Created attachment 779653 [details]
rhsm.log

Description of problem:
Virt-who will crash after system has registered to stage candlepin on the KVM platform

Version-Release number of selected component (if applicable):
[root@hp-z220-05 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 5.10 Beta (Tikanga)
[root@hp-z220-05 ~]# rpm -qa | grep virt-who
virt-who-0.7-9.el5
[root@hp-z220-05 ~]# rpm -qa | grep subscription-manager
subscription-manager-1.8.14-1.el5
subscription-manager-firstboot-1.8.14-1.el5
subscription-manager-gui-1.8.14-1.el5
[root@hp-z220-05 ~]# rpm -qa | grep python-rhsm
python-rhsm-1.8.15-1.el5


How reproducible:
always

Steps to Reproduce:
1.Modify the following configures in the /etc/sysconfig/virt-who (default mode:Use libvirt to list virtual guests):
VIRTWHO_BACKGROUND=1
VIRTWHO_DEBUG=1
VIRTWHO_INTERVAL=5
2.Restart virt-who
#service virt-who restart
3.Modify the following configures in the /etc/rhsm/rhsm.conf:
hostname = subscription.rhn.stage.redhat.com
baseurl= https://cdn.rcm-qa.redhat.com
4.Register to the stage candlepin
#subscription-manager register --username=stage_sam_test --password=redhat
The system has been registered with ID: ca62dabc-16f6-4d57-aaee-9486de0c6a30 
5.Check the virt-who status
[root@hp-z220-06 libvirt-test-API]# service virt-who status
virt-who dead but subsys locked

Actual results:
Virt-who is crash after system has registered to stage candlepin, please see the rhsm.log file in the attachment

Expected results:
Virt-who should normally after system has registered to stage candlepin

Additional info:
When register to the SAM Server ,it hasn't this problem.
Comment 1 Radek Novacek 2013-07-29 03:28:51 EDT
It looks like the server subscription.rhn.stage.redhat.com doesn't provide candlepin API. Do you have correct "prefix" configuration option specified?
Comment 2 Liushihui 2013-07-30 05:20:44 EDT
# Server prefix:
prefix = /subscription

# Server port:
port = 443

(In reply to Radek Novacek from comment #1)
> It looks like the server subscription.rhn.stage.redhat.com doesn't provide
> candlepin API. Do you have correct "prefix" configuration option specified?
Comment 3 Radek Novacek 2013-07-30 06:13:44 EDT
It seems that the server doesn't implement the /status/ command that virt-who uses to test the connection.

What is running at subscription.rhn.stage.redhat.com?
Comment 4 Liushihui 2013-07-31 02:20:19 EDT
Sorry, the stage candlepin server is not under our control so I don't know specificly what is running at subscription.rhn.stage.redhat.com, I just know the version of the stage candlepin server is 0.8.16.

(In reply to Radek Novacek from comment #3)
> It seems that the server doesn't implement the /status/ command that
> virt-who uses to test the connection.
> 
> What is running at subscription.rhn.stage.redhat.com?
Comment 5 Radek Novacek 2013-08-01 05:55:07 EDT
It looks like this server disables the /status/ command. Virt-who can be modified to work without it.
Comment 6 Liushihui 2013-09-09 05:39:38 EDT
Hi Radek,
  I have checked this bug on the RHEL5.10-RC-1.3(20130829.2) against stage candlepin, this bug does not exist any more, if you also confirm this bug should be fixed now, could you please help move the bug status to "ON_QA"? I will move it to VERIFIED then.
Comment 7 Radek Novacek 2013-09-18 09:20:53 EDT
It was not bug in virt-who, should be fixed bin clonepin.
Comment 8 gaoshang 2013-09-23 22:46:46 EDT
per comment 6, mark this bug to VERIFIED
Comment 10 RHEL Product and Program Management 2014-01-22 11:29:25 EST
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 11 Radek Novacek 2014-11-05 07:19:37 EST
This was not bug in virt-who so it was not been added to errata and did not get closed. Closing now.

Note You need to log in before you can comment on or make changes to this bug.