Bug 989379 - Satellite 5.4.1/5.5 on RHEL5 installation fails with rhnlib-2.5.22.1-5.el5
Satellite 5.4.1/5.5 on RHEL5 installation fails with rhnlib-2.5.22.1-5.el5
Status: CLOSED DUPLICATE of bug 951590
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhnlib (Show other bugs)
5.10
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Stephen Herr
Red Hat Satellite QA List
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 03:46 EDT by Jiří Mikulka
Modified: 2014-10-06 09:46 EDT (History)
5 users (show)

See Also:
Fixed In Version: rhnlib-2.5.22.1-6-el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-29 10:24:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiří Mikulka 2013-07-29 03:46:36 EDT
Description of problem:
Installation of Satellite 5.5 on RHEL5 fails if there's latest rhnlib (rhnlib-2.5.22.1-5.el5.noarch.rpm) already installed.

Version-Release number of selected component (if applicable):
Satellite 5.5
rhnlib-2.5.22.1-5.el5.noarch.rpm

How reproducible:
always | regression

Steps to Reproduce:
1. download latest rhnlib build (from brew)
2. install Satellite 5.5
3. check logs

Actual results:
/var/log/rhn/rhn_installation.log:
[...]
--> Processing Conflict: rhnlib conflicts spacewalk-backend < 1.7.38-44
--> Finished Dependency Resolution
rhnlib-2.5.22.1-5.el5.noarch from installed has depsolving problems
  --> rhnlib conflicts with spacewalk-backend
Error: rhnlib conflicts with spacewalk-backend
[...]

Expected results:
Satellite 5.5 is installable with latest rhnlib

Additional info:
Satellite 5.5 is installable on RHEL6 with latest rhnlib-2.5.22-15.el6.noarch.rpm
Comment 1 Jiří Mikulka 2013-07-29 03:55:14 EDT
This issue is also present on RHEL5 when installing Satellite 5.4.1 with rhnlib-2.5.22.1-5.el5 on the machine.

Installation fails with:
--> Processing Conflict: rhnlib conflicts spacewalk-backend < 1.7.38-44
--> Finished Dependency Resolution
rhnlib-2.5.22.1-5.el5.noarch from installed has depsolving problems
  --> rhnlib conflicts with spacewalk-backend
Error: rhnlib conflicts with spacewalk-backend
Comment 2 Jiří Mikulka 2013-07-29 04:30:55 EDT
Overview of Satellite 5.4.1/5.5 vs. rhnlib version:

Satellite 5.4.1 @ RHEL5 @ rhnlib-2.5.22.1-5.el5       | FAIL
Satellite 5.4.1 @ RHEL6 @ rhnlib-2.5.22-15.el6.noarch | OK
Satellite 5.5   @ RHEL5 @ rhnlib-2.5.22.1-5.el5       | FAIL
Satellite 5.5   @ RHEL6 @ rhnlib-2.5.22-15.el6.noarch | OK
Comment 3 Clifford Perry 2013-07-29 05:14:11 EDT
Note - el5 rhnlib conflicts with spacewalk-backend, while el6 does not. 

I believe this conflict statement is legacy and likely can be removed. 

rhnlib-2.5.22.1-5.el5.noarch.rpm

 === conflicts === 
rhncfg < 5.10.27-13
spacewalk-backend < 1.7.38-44


rhnlib-2.5.22-15.el6.noarch.rpm

 === conflicts === 
rhncfg < 5.10.27-13
Comment 4 Martin Minar 2013-07-29 05:29:07 EDT
This problem is on Sat530 too. This effectively blocks all upgrades to 560 on RHEL5.
Comment 5 Jiří Mikulka 2013-07-29 05:29:59 EDT
Tested also on Satellite 5.6:

Satellite 5.6 @ RHEL5 @ rhnlib-2.5.22.1-5.el5       | OK
Satellite 5.6 @ RHEL6 @ rhnlib-2.5.22-15.el6.noarch | OK
Comment 6 Stephen Herr 2013-07-29 09:47:35 EDT
This failure is due to bad / legacy code that was in the rhel 5 rhnlib but not the rhel 6 rhnlib or spacewalk rhnlib. I have removed it, now waiting on the acks to rebuild the package.
Comment 7 Stephen Herr 2013-07-29 10:24:46 EDT
I think we are better served as marking this a FAILS QA against bug 951590 than creating an entirely new bug for it. After all, it makes no sense to include this bug in the list of "bugs this erratum fixes" for customers, since it fixes an internal-only problem that they could never have seen since we fixed it before it was released.

I'm going to close this as DUPLICATE of bug 951590 and update that bug with the correct information.

*** This bug has been marked as a duplicate of bug 951590 ***

Note You need to log in before you can comment on or make changes to this bug.