Bug 989406 - [Config]proxy-logging filter should be added to the sample proxy-server.conf file
[Config]proxy-logging filter should be added to the sample proxy-server.conf ...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-swift (Show other bugs)
2.1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Luis Pabón
pushpesh sharma
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 04:36 EDT by pushpesh sharma
Modified: 2016-11-08 17:25 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:32:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pushpesh sharma 2013-07-29 04:36:59 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:

 
Steps to Reproduce:
1.

Add proxy-logging filter section to proxy-server.conf file
[filterroxy-logging]
 use = egg:swift#proxy_logging
2.
pipeline = healthcheck cache proxy-logging proxy-server
3.

Actual results:


Expected results:

To enable proxy logging these lines should be added to sample proxy-server.conf file.

Additional info:
[root@dhcp207-210 ~]# rpm -qa|grep gluster
gluster-swift-object-1.8.0-6.3.el6rhs.noarch
vdsm-gluster-4.10.2-22.7.el6rhs.noarch
gluster-swift-plugin-1.8.0-2.el6rhs.noarch
glusterfs-geo-replication-3.4.0.12rhs.beta3-1.el6rhs.x86_64
glusterfs-3.4.0.12rhs.beta3-1.el6rhs.x86_64
gluster-swift-1.8.0-6.3.el6rhs.noarch
glusterfs-server-3.4.0.12rhs.beta3-1.el6rhs.x86_64
gluster-swift-proxy-1.8.0-6.3.el6rhs.noarch
gluster-swift-account-1.8.0-6.3.el6rhs.noarch
glusterfs-rdma-3.4.0.12rhs.beta3-1.el6rhs.x86_64
glusterfs-fuse-3.4.0.12rhs.beta3-1.el6rhs.x86_64
gluster-swift-container-1.8.0-6.3.el6rhs.noarch
Comment 2 Luis Pabón 2013-07-29 16:55:38 EDT
On gluster-swift-plugin-1.8.0-4.el6rhs.noarch
Comment 3 pushpesh sharma 2013-08-05 05:39:19 EDT
cat /etc/swift/proxy-server.conf
....
pipeline = catch_errors healthcheck proxy-logging cache proxy-logging proxy-server
....
.....

[filter:proxy-logging]
use = egg:swift#proxy_logging
access_log_level = WARN

....
....

[root@luigi ~]# rpm -qa|grep swift
gluster-swift-container-1.8.0-6.11.el6rhs.noarch
gluster-swift-1.8.0-6.11.el6rhs.noarch
gluster-swift-proxy-1.8.0-6.11.el6rhs.noarch
gluster-swift-account-1.8.0-6.11.el6rhs.noarch
gluster-swift-object-1.8.0-6.11.el6rhs.noarch
gluster-swift-plugin-1.8.0-4.el6rhs.noarch


Marking as verified as the configuration file is updated with proxy-logging filter.
Comment 6 Scott Haines 2013-09-23 18:32:34 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.