Bug 989487 - [RHEVM][backend] gateway on non-rhevm interface is not kept by UI
[RHEVM][backend] gateway on non-rhevm interface is not kept by UI
Status: CLOSED DUPLICATE of bug 995011
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
x86_64 Linux
unspecified Severity high
: ---
: 3.3.0
Assigned To: Alona Kaplan
Martin Pavlik
network
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 07:10 EDT by Martin Pavlik
Modified: 2016-02-10 14:53 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-21 07:22:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log_collector (5.98 MB, application/x-xz)
2013-07-29 07:10 EDT, Martin Pavlik
no flags Details
screenshot 1 (397.33 KB, image/png)
2013-07-29 07:11 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2013-07-29 07:10:12 EDT
Created attachment 779779 [details]
log_collector

Description of problem:
If GW is specified (static or DHCP) on non-rhevm interface, gateway field is displayed empty on next opening of edit network dialog

Version-Release number of selected component (if applicable):
 Red Hat Enterprise Virtualization Manager Version: 3.3.0-0.11.master.el6ev 

How reproducible:
100%

Steps to Reproduce:
1.add logical network to cluster
2.attach the network to host NIC via Setup Networks
3.edit network properties, specify boot protocol static or DHCP, apply changes
4.go to setup networks -> properties of newly attached network (see screenshot)

Actual results:
gateway field is empty

Expected results:
gateway field displays gateway

Additional info:
gateway is set correctly on host 

[root@dell-r210ii-06 ~]# cat /etc/sysconfig/network-scripts/ifcfg-test
DEVICE=test
ONBOOT=yes
TYPE=Bridge
DELAY=0
IPADDR=1.1.1.1
NETMASK=255.255.255.0
GATEWAY=1.1.1.254
BOOTPROTO=none
NM_CONTROLLED=no
STP=no


and it is correctly reported by vdsm

[root@dell-r210ii-06 ~]# vdsClient -s 0 getVdsCaps
	bridges = {'net_67_0': {'addr': '',
	                        'cfg': {'DELAY': '0',
	                                'DEVICE': 'net_67_0',
	                                'NM_CONTROLLED': 'no',
	                                'ONBOOT': 'yes',
	                                'STP': 'no',
	                                'TYPE': 'Bridge'},
	                        'gateway': '0.0.0.0',
	                        'ipv6addrs': [],
	                        'ipv6gateway': '::',
	                        'mtu': '1500',
	                        'netmask': '',
	                        'ports': ['dummy0'],
	                        'stp': 'off'},
	           'rhevm': {'addr': '10.34.66.61',
	                     'cfg': {'BOOTPROTO': 'dhcp',
	                             'DELAY': '0',
	                             'DEVICE': 'rhevm',
	                             'NM_CONTROLLED': 'no',
	                             'ONBOOT': 'yes',
	                             'STP': 'no',
	                             'TYPE': 'Bridge'},
	                     'gateway': '10.34.66.254',
	                     'ipv6addrs': [],
	                     'ipv6gateway': '::',
	                     'mtu': '1500',
	                     'netmask': '255.255.255.0',
	                     'ports': ['em1'],
	                     'stp': 'off'},
	           'test': {'addr': '1.1.1.1',
	                    'cfg': {'BOOTPROTO': 'none',
	                            'DELAY': '0',
	                            'DEVICE': 'test',
	                            'GATEWAY': '1.1.1.254',
	                            'IPADDR': '1.1.1.1',
	                            'NETMASK': '255.255.255.0',
	                            'NM_CONTROLLED': 'no',
	                            'ONBOOT': 'yes',
	                            'STP': 'no',
	                            'TYPE': 'Bridge'},
	                    'gateway': '1.1.1.254',
	                    'ipv6addrs': [],
	                    'ipv6gateway': '::',
	                    'mtu': '1500',
	                    'netmask': '255.255.255.0',
	                    'ports': ['p1p1'],
	                    'stp': 'off'}}
Comment 1 Martin Pavlik 2013-07-29 07:11:56 EDT
Created attachment 779780 [details]
screenshot 1
Comment 2 Martin Pavlik 2013-07-29 07:12:17 EDT
engine.log

2013-07-29 12:16:26,760 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.SetupNetworksVDSCommand] (ajp-/127.0.0.1:8702-3) START, SetupNetworksVDSCommand(HostName = dell-06, HostId = cb99d56b-0381-4325-92c7-060c85dac16f, force=false, checkConnectivity=true, conectivityTimeout=120,
        networks=[test {id=42ae51b0-d8e9-4bf7-995e-7b5376359633, description=null, comment=null, subnet=null, gateway=null, type=null, vlanId=null, stp=false, dataCenterId=6cb8fbde-4bc7-4373-a42f-466c79fcc413, mtu=0, vmNetwork=true, cluster=NetworkCluster {id={clusterId=null, networkId=null}, status=OPERATIONAL, display=false, required=true, migration=false}, providedBy=null, label=null}],
        bonds=[],
        interfaces=[p1p1 {id=331d5151-af63-4f60-a76e-197cb385e61c, vdsId=cb99d56b-0381-4325-92c7-060c85dac16f, name=p1p1, macAddress=90:e2:ba:04:28:c0, networkName=test, bondName=null, bootProtocol=STATIC_IP, address=1.1.1.1, subnet=255.255.255.0, gateway=1.1.1.254, mtu=1500, bridged=true, speed=1000, type=0, networkImplementationDetails={inSync=true, managed=true}},
                p1p2 {id=69082bdd-f0e8-414b-942c-0e09c558d4af, vdsId=cb99d56b-0381-4325-92c7-060c85dac16f, name=p1p2, macAddress=90:e2:ba:04:28:c1, networkName=null, bondName=null, bootProtocol=NONE, address=10.34.67.35, subnet=255.255.255.224, gateway=null, mtu=1500, bridged=false, speed=1000, type=0, networkImplementationDetails=null},
                em1 {id=c7dc5c37-6520-49ae-9802-d9bccce8c58c, vdsId=cb99d56b-0381-4325-92c7-060c85dac16f, name=em1, macAddress=d0:67:e5:f0:83:5e, networkName=rhevm, bondName=null, bootProtocol=DHCP, address=10.34.66.61, subnet=255.255.255.0, gateway=10.34.66.254, mtu=1500, bridged=true, speed=1000, type=2, networkImplementationDetails={inSync=true, managed=true}},
                em2 {id=62193e8f-ed7c-4aca-a936-5c28eb24d60f, vdsId=cb99d56b-0381-4325-92c7-060c85dac16f, name=em2, macAddress=d0:67:e5:f0:83:5f, networkName=null, bondName=null, bootProtocol=NONE, address=, subnet=, gateway=null, mtu=1500, bridged=false, speed=1000, type=0, networkImplementationDetails=null},
                dummy0 {id=65156b0e-e3f5-4eb0-bb64-1331ee2059db, vdsId=cb99d56b-0381-4325-92c7-060c85dac16f, name=dummy0, macAddress=9e:36:24:c6:34:aa, networkName=net_67_0, bondName=null, bootProtocol=NONE, address=, subnet=, gateway=null, mtu=1500, bridged=true, speed=0, type=0, networkImplementationDetails={inSync=true, managed=true}}],
        removedNetworks=[],
        removedBonds=[]), log id: 5bbfc109
Comment 3 Moti Asayag 2013-08-21 07:22:48 EDT

*** This bug has been marked as a duplicate of bug 995011 ***

Note You need to log in before you can comment on or make changes to this bug.