Bug 989541 - Dist-geo-rep : 'gluster volume geo <master_vol> <slave_ip>::<slave_vol> stop' gives wrong error message if session does not exist
Dist-geo-rep : 'gluster volume geo <master_vol> <slave_ip>::<slave_vol> stop'...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Avra Sengupta
:
Depends On: 989248
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 09:39 EDT by Avra Sengupta
Modified: 2014-07-11 15:17 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.5.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 989248
Environment:
Last Closed: 2014-07-11 15:17:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-07-29 09:42:31 EDT
REVIEW: http://review.gluster.org/5417 (glusterd : Checking session created or not in case of geo-rep stop) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 2 Avra Sengupta 2013-07-29 09:43:21 EDT
Performing statefile check in case of geo-rep stop, so as to provide proper error message in case session is not created.

However in case of geo-rep stop force, we allow the command to succeed even in case that the session is not created, because the stop command is a failsafe command to stop running geo-rep sessions on any nodes.
Comment 3 Anand Avati 2013-07-31 03:38:41 EDT
REVIEW: http://review.gluster.org/5417 (glusterd : Checking session created or not in case of geo-rep stop) posted (#2) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 4 Anand Avati 2013-07-31 12:18:41 EDT
COMMIT: http://review.gluster.org/5417 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit d90b46a23a523720f4e40de993ca61ff0ba43617
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Mon Jul 29 19:05:50 2013 +0530

    glusterd : Checking session created or not in case of geo-rep stop
    
    Performing statefile check in case of geo-rep stop, so as to provide
    proper error message in case session is not created.
    
    However in case of geo-rep stop force, we allow the command to succeed
    even in case that the session is not created, because the stop command
    is a failsafe command to stop running geo-rep sessions on any nodes.
    
    Change-Id: I2b6a0253de977633606c422cbbc9e37cede9a268
    BUG: 989541
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/5417
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Note You need to log in before you can comment on or make changes to this bug.