Bug 989583 - [abrt] btrfs-progs-0.20.rc1.20130308git704a08c-1.fc19: extent_io_tree_cleanup: Process /usr/sbin/btrfsck was killed by signal 11 (SIGSEGV)
[abrt] btrfs-progs-0.20.rc1.20130308git704a08c-1.fc19: extent_io_tree_cleanup...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: btrfs-progs (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Josef Bacik
Fedora Extras Quality Assurance
abrt_hash:67f78533c92e7cce0bb437425cd...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 11:07 EDT by Helber Maciel Guerra
Modified: 2013-11-26 10:26 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-26 10:26:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (23.85 KB, text/plain)
2013-07-29 11:07 EDT, Helber Maciel Guerra
no flags Details
File: cgroup (140 bytes, text/plain)
2013-07-29 11:07 EDT, Helber Maciel Guerra
no flags Details
File: core_backtrace (724 bytes, text/plain)
2013-07-29 11:07 EDT, Helber Maciel Guerra
no flags Details
File: dso_list (663 bytes, text/plain)
2013-07-29 11:08 EDT, Helber Maciel Guerra
no flags Details
File: environ (2.09 KB, text/plain)
2013-07-29 11:08 EDT, Helber Maciel Guerra
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-29 11:08 EDT, Helber Maciel Guerra
no flags Details
File: maps (3.53 KB, text/plain)
2013-07-29 11:08 EDT, Helber Maciel Guerra
no flags Details
File: open_fds (105 bytes, text/plain)
2013-07-29 11:08 EDT, Helber Maciel Guerra
no flags Details
File: proc_pid_status (902 bytes, text/plain)
2013-07-29 11:08 EDT, Helber Maciel Guerra
no flags Details
File: var_log_messages (325 bytes, text/plain)
2013-07-29 11:08 EDT, Helber Maciel Guerra
no flags Details

  None (edit)
Description Helber Maciel Guerra 2013-07-29 11:07:42 EDT
Description of problem:
Using fedora 19 live.
Try fsck btrfs.

Version-Release number of selected component:
btrfs-progs-0.20.rc1.20130308git704a08c-1.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/sbin/btrfsck /dev/sdb3
crash_function: extent_io_tree_cleanup
executable:     /usr/sbin/btrfsck
kernel:         3.9.5-301.fc19.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
Thread no. 1 (3 frames)
 #2 extent_io_tree_cleanup at extent_io.c:77
 #3 close_ctree at disk-io.c:1328
 #4 cmd_check at cmds-check.c:3660
Comment 1 Helber Maciel Guerra 2013-07-29 11:07:48 EDT
Created attachment 779976 [details]
File: backtrace
Comment 2 Helber Maciel Guerra 2013-07-29 11:07:52 EDT
Created attachment 779977 [details]
File: cgroup
Comment 3 Helber Maciel Guerra 2013-07-29 11:07:58 EDT
Created attachment 779978 [details]
File: core_backtrace
Comment 4 Helber Maciel Guerra 2013-07-29 11:08:09 EDT
Created attachment 779979 [details]
File: dso_list
Comment 5 Helber Maciel Guerra 2013-07-29 11:08:13 EDT
Created attachment 779980 [details]
File: environ
Comment 6 Helber Maciel Guerra 2013-07-29 11:08:17 EDT
Created attachment 779981 [details]
File: limits
Comment 7 Helber Maciel Guerra 2013-07-29 11:08:21 EDT
Created attachment 779982 [details]
File: maps
Comment 8 Helber Maciel Guerra 2013-07-29 11:08:24 EDT
Created attachment 779983 [details]
File: open_fds
Comment 9 Helber Maciel Guerra 2013-07-29 11:08:45 EDT
Created attachment 779984 [details]
File: proc_pid_status
Comment 10 Helber Maciel Guerra 2013-07-29 11:08:53 EDT
Created attachment 779985 [details]
File: var_log_messages
Comment 11 gatlibs 2013-08-14 01:14:37 EDT
I ran btrfsck --repair /dev/sda3 on an external hard drive. This drive is a copy of an internal drive which failed somehow because of btrfs. It had something to do with "BTRFS error (device sdb3) in open_ctree:2787: errno=-22 unknown (Failed to recover log tree)". That was the error when attempting to mount the partition. I'm assuming that the error in the drive is causing the error in btrfsck.

reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        btrfsck --repair /dev/sdb3
crash_function: extent_io_tree_cleanup
executable:     /usr/sbin/btrfsck
kernel:         3.10.5-201.fc19.x86_64
package:        btrfs-progs-0.20.rc1.20130308git704a08c-1.fc19
reason:         Process /usr/sbin/btrfsck was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            0
Comment 12 Eric Sandeen 2013-09-18 11:52:58 EDT
A new git snapshot of btrfs-progs has been pushed to F19 testing.  If possible, please re-test these bugs & feel free to close or comment as appropriate.

Thanks,
-Eric
Comment 13 Eric Sandeen 2013-11-14 14:31:58 EST
This is a mass update of F19 and F20 btrfs-progs bugs.

A btrfs-progs git snapshot has been built in Rawhide and submitted for F19 and F20 testing.

If your bug was reproducible, please re-test with the new build, and update this bug to let us know if it's been resolved.  If so I can add it to the Bodhi errata.

Thanks,
-Eric
Comment 14 Eric Sandeen 2013-11-26 10:26:32 EST
It's probably clear by now that nobody is going to look at these old abrt bugs on ancient btrfs-progs snapshots.  So let's just be honest about it and close them.

Much newer code is being pushed out to F19 and F20 and rawhide; hopefully new abrt issues can be given more attention in the future.

Note You need to log in before you can comment on or make changes to this bug.